summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm180
1 files changed, 95 insertions, 85 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ac5d08b79b..729078dc69 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -429,7 +429,9 @@ physics settings to tweak as well.")
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no test
- #:configure-flags '("-DDATADIR=share/astromenace")
+ #:configure-flags (list (string-append "-DDATADIR="
+ (assoc-ref %outputs "out")
+ "/share/astromenace"))
#:phases
(modify-phases %standard-phases
(replace 'install
@@ -1811,58 +1813,63 @@ Every puzzle has a complete solution, although there may be more than one.")
(license license:gpl2+)))
(define-public retux
- (package
- (name "retux")
- (version "1.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/retux-game/retux/"
- "releases/download/v"
- (version-major+minor version) "/retux-"
- version "-src.tar.gz"))
- (sha256
- (base32
- "1hxy1pvlxhk0ci3wh2i3mmr82faqdjnnxsiwwr5gcr93nfnw9w5f"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- ;; no setup.py script
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (data (string-append out "/share/retux")))
- (mkdir-p bin)
+ (let ((release "1.4.1")
+ (revision 1))
+ (package
+ (name "retux")
+ (version (if (zero? revision)
+ release
+ (string-append release "-"
+ (number->string revision))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/retux-game/retux/"
+ "releases/download/v"
+ version "/retux-"
+ release "-src.tar.gz"))
+ (sha256
+ (base32
+ "1vrldg2qh2gqfswj7vkpc589ldrrjd903j6cnfdik9zh0jhlq4h2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ ;; no setup.py script
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (data (string-append out "/share/retux")))
+ (mkdir-p bin)
- (substitute* "retux.py"
- ;; Use the correct data directory.
- (("os\\.path\\.join\\(os\\.path\\.dirname\\(__file__\\), \"data\"\\),")
- (string-append "\"" data "\",")))
+ (substitute* "retux.py"
+ ;; Use the correct data directory.
+ (("os\\.path\\.join\\(os\\.path\\.dirname\\(__file__\\), \"data\"\\),")
+ (string-append "\"" data "\",")))
- (copy-file "retux.py" (string-append bin "/retux"))
- (copy-recursively "data" data)
- #t))))))
- (inputs
- `(("python-sge-pygame" ,python-sge-pygame)
- ("python-six" ,python-six)
- ("python-xsge" ,python-xsge)))
- (home-page "https://retux-game.github.io/")
- (synopsis "Action platformer game")
- (description
- "ReTux is an action platformer loosely inspired by the Mario games,
+ (copy-file "retux.py" (string-append bin "/retux"))
+ (copy-recursively "data" data)
+ #t))))))
+ (inputs
+ `(("python-sge-pygame" ,python-sge-pygame)
+ ("python-six" ,python-six)
+ ("python-xsge" ,python-xsge)))
+ (home-page "https://retux-game.github.io/")
+ (synopsis "Action platformer game")
+ (description
+ "ReTux is an action platformer loosely inspired by the Mario games,
utilizing the art assets from the @code{SuperTux} project.")
- ;; GPL version 3 or later is the license for the code and some art.
- ;; The rest of the licenses are for the art exclusively, as listed in
- ;; data/LICENSES.
- (license (list license:cc0
- license:cc-by3.0
- license:cc-by-sa3.0
- license:cc-by-sa4.0
- license:gpl2+
- license:gpl3+))))
+ ;; GPL version 3 or later is the license for the code and some art.
+ ;; The rest of the licenses are for the art exclusively, as listed in
+ ;; data/LICENSES.
+ (license (list license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0
+ license:cc-by-sa4.0
+ license:gpl2+
+ license:gpl3+)))))
(define-public roguebox-adventures
(package
@@ -2721,7 +2728,7 @@ interface or via an external visual interface such as GNU XBoard.")
(ftp-directory . "/chess")))
(license license:gpl3+)))
-(define freedink-engine
+(define-public freedink-engine
(package
(name "freedink-engine")
(version "109.6")
@@ -2751,7 +2758,16 @@ interface or via an external visual interface such as GNU XBoard.")
(invoke "autoreconf")
;; Build fails when autom4te.cache exists.
(delete-file-recursively "autom4te.cache")
- #t)))))
+ #t))
+ (add-after 'install 'delete-freedinkedit-desktop
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; freedinkedit does not know where to find freedink data
+ ;; freedink data is read-only, so it cannot be edited anyway.
+ ;; TODO: fix freedink.desktop
+ (delete-file-recursively (string-append
+ out "/share/applications"))
+ #t))))))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
("cxxtest" ,cxxtest)
@@ -2773,7 +2789,7 @@ game data files but it also supports user-produced game mods or \"D-Mods\".
To that extent, it also includes a front-end for managing all of your D-Mods.")
(license license:gpl3+)))
-(define freedink-data
+(define-public freedink-data
(package
(name "freedink-data")
(version "1.08.20190120")
@@ -3459,15 +3475,15 @@ This game is based on the GPL version of the famous game TuxRacer.")
(define-public supertuxkart
(package
(name "supertuxkart")
- (version "1.1")
+ (version "1.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/supertuxkart/SuperTuxKart/"
- version "/supertuxkart-" version "-src.tar.xz"))
+ version "/SuperTuxKart-" version "-src.tar.xz"))
(sha256
(base32
- "1s0ai07g3sswck9mr0142989mrgzzq1njc1qxk5als5b245jpc79"))
+ "0dvx56hmy6wdhl7m9dw8zc1n3jqfp05gnxl6zs1rbfdyzl5dybh5"))
(modules '((guix build utils)))
(snippet
;; Delete bundled library sources
@@ -3475,12 +3491,9 @@ This game is based on the GPL version of the famous game TuxRacer.")
;; Supertuxkart uses modified versions of the Irrlicht engine
;; and the bullet library. The developers gave an explanation
;; here: http://forum.freegamedev.net/viewtopic.php?f=17&t=3906
- ;; FIXME: try to unbundle angelscript and libraqm
+ ;; FIXME: try to unbundle angelscript, libmcpp and libraqm
(for-each delete-file-recursively
- '("lib/zlib"
- "lib/libpng"
- "lib/jpeglib"
- "lib/glew"
+ '("lib/glew"
"lib/wiiuse"
"lib/enet"))
#t))))
@@ -3489,34 +3502,31 @@ This game is based on the GPL version of the famous game TuxRacer.")
`(#:tests? #f ; no check target
#:configure-flags
(list "-DUSE_WIIUSE=0"
- ;; Do not use the bundled zlib, glew and enet.
- "-DNO_IRR_COMPILE_WITH_ZLIB_=TRUE"
"-DUSE_SYSTEM_GLEW=TRUE"
"-DUSE_SYSTEM_ENET=TRUE"
;; In order to use the system ENet library, IPv6 support (added in
;; SuperTuxKart version 1.1) must be disabled.
"-DUSE_IPV6=FALSE"
;; FIXME: needs libopenglrecorder
- "-DBUILD_RECORDER=0"
- ;; Irrlicht returns an integer instead of a boolean
- "-DCMAKE_C_FLAGS=-fpermissive")))
+ "-DBUILD_RECORDER=0")))
(inputs
- `(("glew" ,glew)
- ("zlib" ,zlib)
- ("openal" ,openal)
- ("libvorbis" ,libvorbis)
+ `(("curl" ,curl)
("freetype" ,freetype)
("fribidi" ,fribidi)
+ ("glew" ,glew)
("harfbuzz" ,harfbuzz)
- ("mesa" ,mesa)
+ ("libvorbis" ,libvorbis)
("libx11" ,libx11)
("libxrandr" ,libxrandr)
- ("curl" ,curl)
+ ("mesa" ,mesa)
+ ("openal" ,openal)
+ ("sdl2" ,sdl2)
+ ("zlib" ,zlib)
;; The following input is needed to build the bundled and modified
;; version of irrlicht.
+ ("enet" ,enet)
("libjpeg" ,libjpeg-turbo)
- ("openssl" ,openssl)
- ("enet" ,enet)))
+ ("openssl" ,openssl)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://supertuxkart.net/Main_Page")
@@ -3664,7 +3674,7 @@ falling, themeable graphics and sounds, and replays.")
(define-public wesnoth
(package
(name "wesnoth")
- (version "1.14.13")
+ (version "1.14.14")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/wesnoth/wesnoth-"
@@ -3673,7 +3683,7 @@ falling, themeable graphics and sounds, and replays.")
"wesnoth-" version ".tar.bz2"))
(sha256
(base32
- "1pmqj4rah0256qi9w394ksb9apid723i5f5agkg6x1lahb1ac91q"))))
+ "1l7mdxn4kw938qz824057rqh99b7y9439a54s64n1xz95w77lp0r"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ;no check target
@@ -3904,7 +3914,7 @@ engine. When you start it you will be prompted to download a graphics set.")
(home-page "http://dev.openttdcoop.org/projects/opengfx")
(synopsis "Base graphics set for OpenTTD")
(description
- "The OpenGFX projects is an implementation of the OpenTTD base grahics
+ "The OpenGFX project is an implementation of the OpenTTD base graphics
set that aims to ensure the best possible out-of-the-box experience.
OpenGFX provides you with...
@@ -4785,7 +4795,7 @@ of war. Widelands also offers an Artificial Intelligence to challenge you.")
(define-public starfighter
(package
(name "starfighter")
- (version "2.3.2")
+ (version "2.3.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4794,7 +4804,7 @@ of war. Widelands also offers an Artificial Intelligence to challenge you.")
version "-src.tar.gz"))
(sha256
(base32
- "1nvi277cazsw36b6nhd5nmk0cjvm71rlxasy24mf18j7fsvq9vp8"))))
+ "0jz2lgvmp299nks6ajg2yxbx4xcaxlc4cpfr61861p7m7z2nv84y"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -7172,7 +7182,7 @@ original.")
("pkg-config" ,pkg-config)))
(inputs
`(("cmocka" ,cmocka)
- ("perl-env-path", perl-env-path)
+ ("perl-env-path" ,perl-env-path)
("perl-inline" ,perl-inline)
("perl-inline-c" ,perl-inline-c)
("perl-string-shellquote" ,perl-string-shellquote)
@@ -7767,7 +7777,7 @@ their own levels.")
(define-public libmanette
(package
(name "libmanette")
- (version "0.2.4")
+ (version "0.2.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libmanette/"
@@ -7775,7 +7785,7 @@ their own levels.")
"libmanette-" version ".tar.xz"))
(sha256
(base32
- "1xrc6rh73v5w3kbkflzv1yg8sbxk4wf06hfk95raxhxlssza9q2g"))))
+ "0awsl0d34k3w18jdiyh377r7qi00s4kmh5gc97vx9jy0h22f01l0"))))
(build-system meson-build-system)
(native-inputs
`(("glib" ,glib "bin") ; for glib-compile-resources
@@ -10168,7 +10178,7 @@ This package is part of the KDE games module.")
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)))
(inputs
- `(("karchive", karchive)
+ `(("karchive" ,karchive)
("kconfig" ,kconfig)
("kconfigwidgets" ,kconfigwidgets)
("kcoreaddons" ,kcoreaddons)
@@ -10314,7 +10324,7 @@ This package is part of the KDE games module.")
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)))
(inputs
- `(("kcompletion", kcompletion)
+ `(("kcompletion" ,kcompletion)
("kconfig" ,kconfig)
("kconfigwidgets" ,kconfigwidgets)
("kcoreaddons" ,kcoreaddons)
@@ -10706,7 +10716,7 @@ This package is part of the KDE games module.")
("kdbusaddons" ,kdbusaddons)
("ki18n" ,ki18n)
("kio" ,kio)
- ("knewstuff", knewstuff)
+ ("knewstuff" ,knewstuff)
("ktextwidgets" ,ktextwidgets)
("kxmlgui" ,kxmlgui)
("libkdegames" ,libkdegames)