summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 55bbad30e6..d148a6a8ff 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Tomáš Čech <sleep_walker@suse.cz>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2018, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016, 2017 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@@ -1323,15 +1323,12 @@ developed mainly for Ren'py.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "module/setup.py"
(("/usr/include/fribidi")
- (string-append (assoc-ref inputs "fribidi")
- "/include/fribidi")))
- #t))
+ (search-input-directory inputs "include/fribidi")))))
(add-after 'set-paths 'set-build-vars
(lambda* (#:key inputs native-inputs #:allow-other-keys)
(setenv "RENPY_CYTHON"
- (string-append (assoc-ref (or native-inputs inputs)
- "python2-cython")
- "/bin/cython"))
+ (search-input-file (or native-inputs inputs)
+ "/bin/cython"))
(setenv "RENPY_DEPS_INSTALL" (string-join (map cdr inputs) ":"))
#t))
(replace 'build
@@ -1375,8 +1372,7 @@ developed mainly for Ren'py.")
`(("python2-future" ,python2-future)
("python2-pygame" ,python2-pygame-sdl2)))
(native-inputs
- `(("gcc" ,gcc-8) ; for const variables as initializer elements
- ("python2-cython" ,python2-cython)))
+ `(("python2-cython" ,python2-cython)))
(home-page "https://www.renpy.org/")
(synopsis "Ren'py python module")
(description "This package contains the shared libraries and Python modules
@@ -1575,7 +1571,7 @@ if __name__ == \"__main__\":
(assoc-ref inputs "python"))
"/site-packages")))
(wrap-program (string-append out "/bin/renpy")
- `("PYTHONPATH" =
+ `("GUIX_PYTHONPATH" =
(,@(delete-duplicates
(map
(lambda (store-path)
@@ -1666,6 +1662,7 @@ also comes with a built-in image and sound editor.")
(method url-fetch)
;; XXX: There is no URL that contains the version. :(
(uri "http://pulkomandy.tk/projects/GrafX2/downloads/21")
+ (file-name (string-append "grafx2-" version ".tgz"))
(sha256
(base32
"0svsy6rqmdj11b400c242i2ixihyz0hds0dgicqz6g6dcgmcl62q"))))
@@ -1682,7 +1679,8 @@ also comes with a built-in image and sound editor.")
;; SDL header files are referenced without the preceeding "SDL/".
(list (string-append "CFLAGS=-I"
(assoc-ref %build-inputs "sdl-union")
- "/include/SDL")
+ "/include/SDL"
+ " -fcommon")
(string-append "prefix="
(assoc-ref %outputs "out")))
#:tests? #f)) ; no check target
@@ -2824,10 +2822,9 @@ support.")
(add-before 'build 'fix-env
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
- (string-append (assoc-ref inputs "sdl2-union")
- "/include/SDL2:"
- (or (getenv "CPATH") "")))
- #t))
+ (string-append
+ (search-input-directory inputs "include/SDL2")
+ ":" (or (getenv "CPATH") "")))))
(add-after 'install 'really-install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))