summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-23 11:22:30 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-23 11:29:38 +0100
commitb15e543d303ea58fdc0f0541c708389f9d513e3d (patch)
tree5c4bd48d67d4d3cd4806269dcabf58382f448bed /gnu/packages/game-development.scm
parent4efc08d895274ee39e6e6e5c49121fb05a0281b6 (diff)
parentdaf7b5ecef8de0e536ffd8d2957f022d010767a8 (diff)
downloadguix-patches-b15e543d303ea58fdc0f0541c708389f9d513e3d.tar
guix-patches-b15e543d303ea58fdc0f0541c708389f9d513e3d.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 6aef26388a..d148a6a8ff 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1016,6 +1017,59 @@ the creation of animations, tiled graphics, texture atlases, and more.")
(home-page "https://www.aseprite.org/")
(license license:gpl2+)))
+(define-public libresprite
+ (package
+ (name "libresprite")
+ (version "1.0")
+ ;; TODO: Unbundle third party software.
+ ;; - duktape is bundled inside the project but it's hard to unbundle:
+ ;; there are many differences from a version to the next and it is not
+ ;; really designed to work as a shared lib.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LibreSprite/LibreSprite")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0djbjjh21ahlxzh0b0jp4mpfycam8h9157i4wbxkd618fraadhbp"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ (list "-DWITH_WEBP_SUPPORT=1")
+ ;; Tests are unmaintained
+ #:tests? #f))
+ (native-inputs
+ `(("gcc@10" ,gcc-10) ; Requires 8.5 or higher
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("freetype" ,freetype)
+ ("giflib" ,giflib)
+ ("googletest" ,googletest)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libwebp" ,libwebp)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxxf86dga" ,libxxf86dga)
+ ("libxxf86vm" ,libxxf86vm)
+ ("lua" ,lua) ; Optional
+ ("pixman" ,pixman)
+ ("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("tinyxml" ,tinyxml)
+ ("zlib" ,zlib)))
+ (synopsis "Animated sprite editor and pixel art tool")
+ (description "LibreSprite is a tool for creating 2D pixel art for video
+games. In addition to basic pixel editing features, it can assist in the
+creation of animations, tiled graphics, texture atlases, and more.
+LibreSprite is a fork of the latest GPLv2 commit of Aseprite.")
+ (home-page "https://libresprite.github.io/")
+ (license license:gpl2+)))
+
(define-public qqwing
(package
(name "qqwing")