summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 826de90ccc..8822ff35da 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -188,7 +188,7 @@ by the b43-open driver of Linux-libre.")
(name (string-replace-substring
(string-append "opensbi-" platform "-" variant)
"_" "-"))
- (version "0.5")
+ (version "0.6")
(source
(origin
(method git-fetch)
@@ -197,7 +197,7 @@ by the b43-open driver of Linux-libre.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0qc73xbiy79qqkwxmp4mg15q8n8k26njkyqb6n0jw5dyibd6hb85"))))
+ (base32 "129ypdga0fzn657n2f42g2a1vx3hf8x7sd78h06d35pgkry0jkl7"))))
(build-system gnu-build-system)
(native-inputs
`(,@(if (and (not (string-prefix? "riscv64" (%current-system)))
@@ -240,12 +240,14 @@ for platform-specific firmwares executing in M-mode.")
(define-public opensbi-qemu-virt
(make-opensbi-package "qemu" "virt"))
-(define-public opensbi-qemu-sifive-u
- (make-opensbi-package "qemu" "sifive_u"))
-
(define-public opensbi-sifive-fu540
(make-opensbi-package "sifive" "fu540"))
+(define-public opensbi-qemu-sifive-u
+ ;; Dropped upstream, as all functionality is present in the sifive-fu540
+ ;; target for recent versions of qemu, u-boot and linux.
+ (deprecated-package "opensbi-qemu-sifive-u" opensbi-sifive-fu540))
+
(define-public seabios
(package
(name "seabios")