summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 3fa0a4d331..3f5f7b1285 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -86,7 +86,7 @@
(define-public bitcoin-core
(package
(name "bitcoin-core")
- (version "0.17.1")
+ (version "0.18.0")
(source (origin
(method url-fetch)
(uri
@@ -94,7 +94,7 @@
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "0am4pnaf2cisv172jqx6jdpzx770agm8777163lkjbw3ryslymiy"))))
+ "0ps0vw9iknz1b1sx74rabd1yhlxvwbd0aimjzn9hlqkvw286hkjy"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -102,7 +102,7 @@
("util-linux" ,util-linux) ; provides the hexdump command for tests
("qttools" ,qttools)))
(inputs
- `(("bdb" ,bdb-5.3) ; with 6.2.23, there is an error: ambiguous overload
+ `(("bdb" ,bdb-4.8) ; Bitcoin Core requires bdb 4.8 for compatibility
("boost" ,boost)
("libevent" ,libevent)
("miniupnpc" ,miniupnpc)
@@ -112,8 +112,6 @@
(arguments
`(#:configure-flags
(list
- ;; We use a bdb version newer than 4.8.
- "--with-incompatible-bdb"
;; Boost is not found unless specified manually.
(string-append "--with-boost="
(assoc-ref %build-inputs "boost"))
@@ -136,6 +134,11 @@
(add-before 'check 'set-home
(lambda _
(setenv "HOME" (getenv "TMPDIR")) ; Tests write to $HOME.
+ #t))
+ (add-after 'check 'check-functional
+ (lambda _
+ (invoke "python3" "./test/functional/test_runner.py"
+ (string-append "--jobs=" (number->string (parallel-job-count))))
#t)))))
(home-page "https://bitcoin.org/en/")
(synopsis "Bitcoin peer-to-peer client")