summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-17 16:17:20 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-17 16:27:15 +0200
commit9ff87bb99614923fa3336ab4bbf22e3444709b48 (patch)
treefa169a6cc0fdc8d92bb4c4a4f265afc2ba29a890 /gnu/packages/finance.scm
parentae71bef532d6b1c9d1481a3ac65827f148b1e45b (diff)
parent9e8e252026f558933bdd9cfc26a75d13954b3e8e (diff)
downloadguix-patches-9ff87bb99614923fa3336ab4bbf22e3444709b48.tar
guix-patches-9ff87bb99614923fa3336ab4bbf22e3444709b48.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm31
1 files changed, 23 insertions, 8 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index e8c4e6bc9d..3f5f7b1285 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -476,16 +476,20 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
("git" ,git)
("graphviz" ,graphviz)
("pkg-config" ,pkg-config)
+ ("protobuf" ,protobuf)
+ ("python" ,python)
("qttools" ,qttools)))
(inputs
`(("boost" ,boost)
("cppzmq" ,cppzmq)
("expat" ,expat)
("hidapi" ,hidapi)
- ("libunwind" ,libunwind)
("libsodium" ,libsodium)
+ ("libunwind" ,libunwind)
+ ("libusb" ,libusb)
("miniupnpc" ,miniupnpc)
("openssl" ,openssl)
+ ("protobuf" ,protobuf)
("rapidjson" ,rapidjson)
("readline" ,readline)
("unbound" ,unbound)
@@ -493,9 +497,12 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
("zeromq" ,zeromq)))
(arguments
`(#:out-of-source? #t
- #:configure-flags '("-DARCH=default"
- "-DBUILD_TESTS=ON"
- "-DBUILD_GUI_DEPS=ON")
+ #:configure-flags
+ (list "-DARCH=default"
+ "-DBUILD_TESTS=ON"
+ "-DBUILD_GUI_DEPS=ON"
+ (string-append "-DReadline_ROOT_DIR="
+ (assoc-ref %build-inputs "readline")))
#:phases
(modify-phases %standard-phases
;; tests/core_tests need a valid HOME
@@ -534,7 +541,13 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
":")))
(invoke "tests/unit_tests/unit_tests"
(string-append "--gtest_filter=-"
- excluded-unit-tests))))))))
+ excluded-unit-tests)))))
+ (add-after 'install 'delete-dead-links
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file (string-append out "/lib/libprotobuf.so"))
+ (delete-file (string-append out "/lib/libusb-1.0.so"))
+ #t))))))
(home-page "https://getmonero.org/")
(synopsis "Command-line interface to the Monero currency")
(description
@@ -545,7 +558,7 @@ the Monero command line client and daemon.")
(define-public monero-gui
(package
(name "monero-gui")
- (version "0.14.1.0")
+ (version "0.14.1.2")
(source
(origin
(method git-fetch)
@@ -555,7 +568,7 @@ the Monero command line client and daemon.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ilx47771faygf97wilm64xnqxgxa3b43q0g9v014npk0qj8pc31"))))
+ "1rm043r6y2mzy8pclnzbjjfxgps8pkfa2b92p66k8y8rdmgq6m1k"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -563,9 +576,11 @@ the Monero command line client and daemon.")
(inputs
`(("boost" ,boost)
("hidapi" ,hidapi)
- ("libunwind" ,libunwind)
("libsodium" ,libsodium)
+ ("libunwind" ,libunwind)
+ ("libusb" ,libusb)
("openssl" ,openssl)
+ ("protobuf" ,protobuf)
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtgraphicaleffects" ,qtgraphicaleffects)