summaryrefslogtreecommitdiff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 0b4cae98ba..a90ab9c98e 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -26,7 +26,6 @@
(define-public file
(package
- (replacement file/fixed)
(name "file")
(version "5.19")
(source (origin
@@ -46,14 +45,13 @@ of the file.")
(license bsd-2)
(home-page "http://www.darwinsys.com/file/")))
-(define file/fixed ;fix for CVE-2014-3710
- (let ((real-version "5.20"))
- (package (inherit file)
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
- real-version ".tar.gz"))
- (sha256
- (base32
- "0iyjs9z8kp43gz7gva4j67h4p0n53f7q8x3ibai9s01sp3xnphsv"))))
- (replacement #f))))
+(define-public file-5.20 ;fix for CVE-2014-3710
+ (package (inherit file)
+ (version "5.20")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0iyjs9z8kp43gz7gva4j67h4p0n53f7q8x3ibai9s01sp3xnphsv"))))))