summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 25975e9d55..40fd389f11 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9854,3 +9854,24 @@ compilation/grep buffers. Works with @code{wgrep}, @code{ack}, @code{ag},
(synopsis "Interactive align-regexp command in Emacs")
(description "Interactive align-regexp command in Emacs")
(license license:gpl3+)))
+
+(define-public emacs-shift-number
+ (package
+ (name "emacs-shift-number")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/alezost/shift-number.el"
+ "/archive/" "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1g79m0hqn9jgpm565vvh8pdfzndc4vw7xisnh5qysj55qfg8cb1x"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/alezost/shift-number.el")
+ (synopsis "Increase or decrease the number at point")
+ (description "@code{emacs-shift-number} provides commands
+@code{shift-number-up} to increase and @code{shift-number-down} to
+decrease the number at point.")
+ (license license:gpl3+)))