summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 44f902b3ad..847871a95f 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -372,7 +372,7 @@ built-in registry server of Docker.")
((substitute-LookPath source-text package
relative-path)
#`(substitute* source-files
- ((#,(string-append "exec\\.LookPath\\(\""
+ ((#,(string-append "\\<exec\\.LookPath\\(\""
(syntax->datum
#'source-text)
"\")"))
@@ -386,11 +386,12 @@ built-in registry server of Docker.")
((substitute-LookPath source-text package
relative-path)
#`(substitute* source-files
- ((#,(string-append "exec\\.Command\\(\""
+ ((#,(string-append "\\<(re)?exec\\.Command\\(\""
(syntax->datum
#'source-text)
- "\""))
- (string-append "exec.Command(\""
+ "\"") _ re?)
+ (string-append (if re? re? "")
+ "exec.Command(\""
(assoc-ref inputs package)
relative-path
"\""))))))))