summaryrefslogtreecommitdiff
path: root/gnu/packages/debian.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/debian.scm')
-rw-r--r--gnu/packages/debian.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index d3438a1f4c..e1dd9d1485 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -129,6 +129,7 @@ contains the archive keys used for that.")
(add-after 'unpack 'patch-source
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ (coreutils (assoc-ref inputs "coreutils"))
(wget (assoc-ref inputs "wget"))
(debian (assoc-ref inputs "debian-keyring"))
(ubuntu (assoc-ref inputs "ubuntu-keyring")))
@@ -141,6 +142,7 @@ contains the archive keys used for that.")
(substitute* "scripts/gutsy"
(("/usr") ubuntu))
(substitute* "debootstrap"
+ (("chroot ") (string-append coreutils "/bin/chroot "))
(("=/usr") (string-append "=" out)))
(substitute* "functions"
(("wget ") (string-append wget "/bin/wget ")))
@@ -154,7 +156,8 @@ contains the archive keys used for that.")
#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
#:tests? #f)) ; no tests
(inputs
- `(("debian-keyring" ,debian-archive-keyring)
+ `(("coreutils" ,coreutils)
+ ("debian-keyring" ,debian-archive-keyring)
("ubuntu-keyring" ,ubuntu-keyring)
("wget" ,wget)))
;; The following are required for debootstrap to work correctly