summaryrefslogtreecommitdiff
path: root/gnu/packages/debian.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-06-05 16:13:23 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-06-08 11:07:51 -0400
commit129948dcbda91d4449b56e3816eede249e34afb6 (patch)
treebd387206478776c09ed59d918c3dbbaef8edc7c6 /gnu/packages/debian.scm
parentad3a5807166f4226bb1f13104c35a4716403e305 (diff)
downloadguix-patches-129948dcbda91d4449b56e3816eede249e34afb6.tar
guix-patches-129948dcbda91d4449b56e3816eede249e34afb6.tar.gz
gnu: debootstrap: Substitute chroot in 'patch-source' phase.
* gnu/packages/debian.scm (debootstrap)[arguments]: In 'patch-source' phase, substitute chroot in the debootstrap script file. [inputs]: Add coreutils.
Diffstat (limited to 'gnu/packages/debian.scm')
-rw-r--r--gnu/packages/debian.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index d3438a1f4c..e1dd9d1485 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -129,6 +129,7 @@ contains the archive keys used for that.")
(add-after 'unpack 'patch-source
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ (coreutils (assoc-ref inputs "coreutils"))
(wget (assoc-ref inputs "wget"))
(debian (assoc-ref inputs "debian-keyring"))
(ubuntu (assoc-ref inputs "ubuntu-keyring")))
@@ -141,6 +142,7 @@ contains the archive keys used for that.")
(substitute* "scripts/gutsy"
(("/usr") ubuntu))
(substitute* "debootstrap"
+ (("chroot ") (string-append coreutils "/bin/chroot "))
(("=/usr") (string-append "=" out)))
(substitute* "functions"
(("wget ") (string-append wget "/bin/wget ")))
@@ -154,7 +156,8 @@ contains the archive keys used for that.")
#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
#:tests? #f)) ; no tests
(inputs
- `(("debian-keyring" ,debian-archive-keyring)
+ `(("coreutils" ,coreutils)
+ ("debian-keyring" ,debian-archive-keyring)
("ubuntu-keyring" ,ubuntu-keyring)
("wget" ,wget)))
;; The following are required for debootstrap to work correctly