summaryrefslogtreecommitdiff
path: root/gnu/packages/cyrus-sasl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cyrus-sasl.scm')
-rw-r--r--gnu/packages/cyrus-sasl.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 3e65a1faf6..691349a38f 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -45,6 +45,7 @@
(sha256 (base32
"1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
(patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"))))
+ (replacement cyrus-sasl/fixed)
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -80,3 +81,20 @@ server writers.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
(home-page "https://cyrusimap.org/sasl/")))
+
+(define-public cyrus-sasl/fixed
+ (package
+ (inherit cyrus-sasl)
+ (version "2.1.27")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append
+ "https://cyrusimap.org/releases/cyrus-sasl-"
+ version ".tar.gz")
+ (string-append
+ "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
+ version ".tar.gz")))
+ (sha256 (base32
+ "1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
+ (patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"
+ "cyrus-sasl-CVE-2019-19906.patch"))))))