summaryrefslogtreecommitdiff
path: root/gnu/packages/cyrus-sasl.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 11:49:35 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 11:51:09 +0100
commit70128b8afacf332b0aff69ebcad6868fd158e8ad (patch)
tree5a18002024f7a6d2828ec7db55cc11e5ebf0df57 /gnu/packages/cyrus-sasl.scm
parentfb4ccb86c26cc06d090576a6c281b5bb417f1ec9 (diff)
downloadguix-patches-70128b8afacf332b0aff69ebcad6868fd158e8ad.tar
guix-patches-70128b8afacf332b0aff69ebcad6868fd158e8ad.tar.gz
gnu: cyrus-sasl: Fix CVE-2019-19906.
* gnu/packages/patches/cyrus-sasl-CVE-2019-19906.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/cyrus-sasl.scm (cyrus-sasl/fixed): New variable. Apply patch. (cyrus-sasl)[replacement]: Graft.
Diffstat (limited to 'gnu/packages/cyrus-sasl.scm')
-rw-r--r--gnu/packages/cyrus-sasl.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 3e65a1faf6..691349a38f 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -45,6 +45,7 @@
(sha256 (base32
"1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
(patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"))))
+ (replacement cyrus-sasl/fixed)
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -80,3 +81,20 @@ server writers.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
(home-page "https://cyrusimap.org/sasl/")))
+
+(define-public cyrus-sasl/fixed
+ (package
+ (inherit cyrus-sasl)
+ (version "2.1.27")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append
+ "https://cyrusimap.org/releases/cyrus-sasl-"
+ version ".tar.gz")
+ (string-append
+ "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
+ version ".tar.gz")))
+ (sha256 (base32
+ "1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
+ (patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"
+ "cyrus-sasl-CVE-2019-19906.patch"))))))