summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 73049a71a5..7750c4ab82 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37219,6 +37219,34 @@ and would-block I/O operations.")
("rust-tokio-core" ,rust-tokio-core-0.1))))
(license license:bsd-3)))
+(define-public rust-password-hash-0.3
+ (package
+ (name "rust-password-hash")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "password-hash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1n7ig9j5x2q0fk12nny40faggrs0ra5bbxp6gz5yghfwlqw1ay8x"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-base64ct" ,rust-base64ct-1)
+ ("rust-rand-core" ,rust-rand-core-0.6)
+ ("rust-subtle" ,rust-subtle-2))))
+ (home-page "https://github.com/RustCrypto/traits/tree/master/password-hash")
+ (synopsis
+ "Traits describing the functionality of password hashing algorithms")
+ (description
+ "This package provides traits which describe the functionality of
+password hashing algorithms, as well as a `no_std`-friendly implementation of
+the PHC string format (a well-defined subset of the Modular Crypt
+Format (MCF).")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-paste-1
(package
(name "rust-paste")