summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 9bc9771dc1..3720383664 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -182,7 +182,7 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(wrap-program
(string-append (assoc-ref outputs "out")
"/share/gtags/script/pygments_parser.py")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))
+ `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))))
(add-after 'install 'post-install
(lambda* (#:key outputs #:allow-other-keys)
;; Install the plugin files in the right place.
@@ -335,6 +335,10 @@ cloc can handle a greater variety of programming languages.")
(base32
"0w1icjqd8hd45rn1y6nbfznk1a6ip54whwbfbhxp7ws2hn3ilqnr"))))
(build-system gnu-build-system)
+ (arguments
+ ;; Required since GCC 10, see:
+ ;; https://gcc.gnu.org/gcc-10/porting_to.html.
+ `(#:configure-flags (list "CFLAGS=-fcommon")))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -700,7 +704,7 @@ importantly we give you proper follow-symbol and find-references support.")
(substitute* "colormake"
(("colormake\\.pl") (string-append bin "/colormake.pl"))
(("/bin/bash")
- (string-append (assoc-ref %build-inputs "bash") "/bin/sh")))
+ (search-input-file %build-inputs "/bin/sh")))
(install-file "colormake.1" (string-append doc "/man/man1"))
(install-files '("AUTHORS" "BUGS" "ChangeLog" "README") doc)
(install-files '("colormake" "colormake-short" "clmake"