summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
commit9bc0f45df5d6aed217020b1183dca54989844fb0 (patch)
treed927e89949ff7f65b5059bc94273c53fd43d0763 /gnu/packages/code.scm
parent6db3c536e89deb8a204e756f427614925a7d2582 (diff)
parent10554e0a57feeea470127a1d0441957d1776b0bd (diff)
downloadguix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar
guix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index cdd9e3306b..3720383664 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages xml))
@@ -575,31 +576,32 @@ results and determine build stability.")
(define-public kcov
(package
(name "kcov")
- (version "38")
+ (version "39")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/SimonKagstrom/kcov")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0zqg21xwivi16csl6a5wby6679ny01bjaw4am3y4qcgjdyihifp8"))))
+ "09wf1k4dlpdhqjjgq2bibmgy8i3z32wf0zxhd2px2dvg92m4zwqr"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;no test target
+ `(#:tests? #f ; no test target
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-/bin/bash-references
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
(substitute* (find-files "src" ".*\\.cc?$")
- (("/bin/bash") (which "bash"))
- (("/bin/sh") (which "sh")))
- #t)))))
+ (("/bin/(bash|sh)" shell)
+ (string-append (assoc-ref inputs "bash") shell)))))))))
(inputs
`(("curl" ,curl)
("elfutils" ,elfutils)
("libelf" ,libelf)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(native-inputs
`(("python" ,python)))
@@ -748,7 +750,7 @@ independent targets.")
(define-public uncrustify
(package
(name "uncrustify")
- (version "0.69.0")
+ (version "0.74.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -757,11 +759,10 @@ independent targets.")
(file-name (git-file-name name version))
(sha256
(base32
- "0sqrg13kp8fwymq40976bq380bzw40g4ss7ihlbq45d0f90ifa1k"))))
+ "0v48vhmzxjzysbf0vhxzayl2pkassvbabvwg84xd6b8n5i74ijxd"))))
(build-system cmake-build-system)
(native-inputs
- `(("unzip" ,unzip)
- ("python" ,python-wrapper)))
+ `(("python" ,python-wrapper)))
(arguments
`(#:phases
(modify-phases %standard-phases