summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index bb7767670d..c8e76b8ab4 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -74,8 +74,10 @@
(modules '((guix build utils)))
(snippet
;; Fix compilation with glibc >= 2.26, which removed xlocale.h.
- '(substitute* "c/expeditor.c"
- (("xlocale\\.h") "locale.h")))))
+ '(begin
+ (substitute* "c/expeditor.c"
+ (("xlocale\\.h") "locale.h"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("ncurses" ,ncurses)