summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 9a18b77ff0..88247cc911 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -218,8 +218,7 @@ programs and other files depend.")
(add-before 'configure 'set-build-environment
(lambda _
(setenv "CC" "gcc") (setenv "CXX" "g++")
- (setenv "AR" "ar")
- #t))
+ (setenv "AR" "ar")))
(replace 'configure
(lambda _
(invoke "python" "build/gen.py"
@@ -234,16 +233,15 @@ programs and other files depend.")
(string-append
"#define LAST_COMMIT_POSITION_NUM ~a\n"
"#define LAST_COMMIT_POSITION \"~a (~a)\"\n")
- ,revision ,revision ,(string-take commit 8))
- #t))))
+ ,revision ,revision ,(string-take commit 8))))))
(replace 'build
(lambda _
(invoke "ninja" "-C" "out" "gn"
"-j" (number->string (parallel-job-count)))))
(replace 'check
- (lambda* (#:key (tests? #t) #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(if tests?
- (lambda ()
+ (begin
(invoke "ninja" "-C" "out" "gn_unittests"
"-j" (number->string (parallel-job-count)))
(invoke "./out/gn_unittests"))
@@ -251,11 +249,10 @@ programs and other files depend.")
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (install-file "out/gn" (string-append out "/bin"))
- #t))))))
+ (install-file "out/gn" (string-append out "/bin"))))))))
(native-inputs
`(("ninja" ,ninja)
- ("python" ,python-2)))
+ ("python" ,python-wrapper)))
(synopsis "Generate Ninja build files")
(description
"GN is a tool that collects information about a project from @file{.gn}