summaryrefslogtreecommitdiff
path: root/gnu/packages/autogen.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/autogen.scm')
-rw-r--r--gnu/packages/autogen.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index 704a5d1342..2b90623e5d 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -46,16 +46,16 @@
(inputs `(("which" ,which)
("guile" ,guile-2.0)))
(arguments
- '(#:phases (alist-cons-before
- 'patch-source-shebangs 'patch-test-scripts
- (lambda _
- (let ((sh (which "sh")))
- (substitute*
- (append (find-files "agen5/test" "\\.test$")
- (find-files "autoopts/test" "\\.(test|in)$"))
- (("/bin/sh") sh)
- (("/usr/bin/tr") "tr"))))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'patch-source-shebangs 'patch-test-scripts
+ (lambda _
+ (let ((sh (which "sh")))
+ (substitute*
+ (append (find-files "agen5/test" "\\.test$")
+ (find-files "autoopts/test" "\\.(test|in)$"))
+ (("/bin/sh") sh)
+ (("/usr/bin/tr") "tr"))))))))
(home-page "http://www.gnu.org/software/autogen/")
(synopsis "Automated program generator")
(description