summaryrefslogtreecommitdiff
path: root/gnu/packages/autogen.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-31 22:24:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-31 22:24:59 +0300
commit99e4aa54a6cba0136335b3b525966ac2793cbb8a (patch)
treee08802b2dd6de77214f20f5e3c3348333ba99d95 /gnu/packages/autogen.scm
parente85ff3e2fdb8979e4482e99c218a8d6d76504e5f (diff)
downloadguix-patches-99e4aa54a6cba0136335b3b525966ac2793cbb8a.tar
guix-patches-99e4aa54a6cba0136335b3b525966ac2793cbb8a.tar.gz
gnu: autogen: Use 'modify-phases'.
* gnu/packages/autogen.scm (autogen)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/autogen.scm')
-rw-r--r--gnu/packages/autogen.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index 704a5d1342..2b90623e5d 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -46,16 +46,16 @@
(inputs `(("which" ,which)
("guile" ,guile-2.0)))
(arguments
- '(#:phases (alist-cons-before
- 'patch-source-shebangs 'patch-test-scripts
- (lambda _
- (let ((sh (which "sh")))
- (substitute*
- (append (find-files "agen5/test" "\\.test$")
- (find-files "autoopts/test" "\\.(test|in)$"))
- (("/bin/sh") sh)
- (("/usr/bin/tr") "tr"))))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'patch-source-shebangs 'patch-test-scripts
+ (lambda _
+ (let ((sh (which "sh")))
+ (substitute*
+ (append (find-files "agen5/test" "\\.test$")
+ (find-files "autoopts/test" "\\.(test|in)$"))
+ (("/bin/sh") sh)
+ (("/usr/bin/tr") "tr"))))))))
(home-page "http://www.gnu.org/software/autogen/")
(synopsis "Automated program generator")
(description