summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 03c575c95b..2d0804acc6 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -203,25 +203,24 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
("mpfr" ,mpfr))) ; header files from both are included by flint/arith.h
(arguments
`(#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gmp (assoc-ref inputs "gmp"))
- (mpfr (assoc-ref inputs "mpfr")))
- ;; Drop test failing with gmp-6 due to changed invertibility
- ;; of 0 in Z/1 Z, which according to the flint authors has no
- ;; impact on flint.
- ;; FIXME: Drop with later version.
- (delete-file "fmpz/test/t-invmod.c")
- ;; do not pass "--enable-fast-install", which makes the
- ;; homebrew configure process fail
- (zero? (system*
- "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-gmp=" gmp)
- (string-append "--with-mpfr=" mpfr)))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gmp (assoc-ref inputs "gmp"))
+ (mpfr (assoc-ref inputs "mpfr")))
+ ;; Drop test failing with gmp-6 due to changed invertibility
+ ;; of 0 in Z/1 Z, which according to the flint authors has no
+ ;; impact on flint.
+ ;; FIXME: Drop with later version.
+ (delete-file "fmpz/test/t-invmod.c")
+ ;; do not pass "--enable-fast-install", which makes the
+ ;; homebrew configure process fail
+ (zero? (system*
+ "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-gmp=" gmp)
+ (string-append "--with-mpfr=" mpfr)))))))))
(synopsis "Fast library for number theory")
(description
"FLINT is a C library for number theory. It supports arithmetic