summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 3540d40603..c74b68c309 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -53,15 +53,16 @@
(("/bin/sh") (which "sh")))
#t))
(add-before 'check 'patch-tests
- ;; The coreutils do not have an ACL bit to remove from their
- ;; output, so the sed expression that removes the bit is disabled.
- (substitute* "test/sbits-restore.test"
- (("\\| sed.*'") ""))
- ;; These tests require the existence of a user named "bin", but
- ;; this user does not exist within Guix's build environment.
- (for-each (lambda (file)
- (delete-file (string-append "test/" file)))
- '("setfacl-X.test" "cp.test" "misc.test")))
+ (lambda _
+ ;; The coreutils do not have an ACL bit to remove from their
+ ;; output, so the sed expression that removes the bit is disabled.
+ (substitute* "test/sbits-restore.test"
+ (("\\| sed.*'") ""))
+ ;; These tests require the existence of a user named "bin", but
+ ;; this user does not exist within Guix's build environment.
+ (for-each (lambda (file)
+ (delete-file (string-append "test/" file)))
+ '("setfacl-X.test" "cp.test" "misc.test"))))
(replace 'install
(lambda _
(zero? (system* "make" "install" "install-lib" "install-dev")))))))