summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-04 13:07:39 -0400
committerLeo Famulari <leo@famulari.name>2017-11-04 13:09:06 -0400
commit7183c4bf570b09277f82c6487566e81d88ae2fcb (patch)
tree2e1c9341ee960a08cf65f9fbcda1452b1210cdd9 /gnu/packages/acl.scm
parent2d433b5363fecba0d63caa1844c937dec4ccc23b (diff)
downloadguix-patches-7183c4bf570b09277f82c6487566e81d88ae2fcb.tar
guix-patches-7183c4bf570b09277f82c6487566e81d88ae2fcb.tar.gz
gnu: acl: Fix typo.
This is a followup commit to 2d433b5363fecba0d63caa1844c937dec4ccc23b, fixing a typo introduced while rebasing the commit. gnu/packages/acl.scm (acl)[arguments]: Fix typo in patch-tests phase.
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 3540d40603..c74b68c309 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -53,15 +53,16 @@
(("/bin/sh") (which "sh")))
#t))
(add-before 'check 'patch-tests
- ;; The coreutils do not have an ACL bit to remove from their
- ;; output, so the sed expression that removes the bit is disabled.
- (substitute* "test/sbits-restore.test"
- (("\\| sed.*'") ""))
- ;; These tests require the existence of a user named "bin", but
- ;; this user does not exist within Guix's build environment.
- (for-each (lambda (file)
- (delete-file (string-append "test/" file)))
- '("setfacl-X.test" "cp.test" "misc.test")))
+ (lambda _
+ ;; The coreutils do not have an ACL bit to remove from their
+ ;; output, so the sed expression that removes the bit is disabled.
+ (substitute* "test/sbits-restore.test"
+ (("\\| sed.*'") ""))
+ ;; These tests require the existence of a user named "bin", but
+ ;; this user does not exist within Guix's build environment.
+ (for-each (lambda (file)
+ (delete-file (string-append "test/" file)))
+ '("setfacl-X.test" "cp.test" "misc.test"))))
(replace 'install
(lambda _
(zero? (system* "make" "install" "install-lib" "install-dev")))))))