summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a8133d669..d479032f83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -990,7 +990,10 @@ download-po.$(1):
if wget -nv -O "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" \
"https://translate.fedoraproject.org/api/translations/guix/$(1)/$$$$lang/file/" ; \
then \
- mv "$(top_srcdir)/$(2)/$(3)$$$$lang.po"{.tmp,} ; \
+ msgfilter --no-wrap -i "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" \
+ cat > "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp2" ; \
+ rm "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" ; \
+ mv "$(top_srcdir)/$(2)/$(3)$$$$lang.po"{.tmp2,} ; \
else \
rm "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" ; \
fi ; \