summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/finance.scm18
-rw-r--r--gnu/packages/patches/bitcoin-core-python-compat.patch28
3 files changed, 13 insertions, 34 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 217c05eab6..a1da838aee 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -846,7 +846,6 @@ dist_patch_DATA = \
%D%/packages/patches/binutils-loongson-workaround.patch \
%D%/packages/patches/binutils-mingw-w64-timestamp.patch \
%D%/packages/patches/binutils-mingw-w64-deterministic.patch \
- %D%/packages/patches/bitcoin-core-python-compat.patch \
%D%/packages/patches/blender-2.79-gcc8.patch \
%D%/packages/patches/blender-2.79-gcc9.patch \
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7b87bde50c..7ef40f544f 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -108,7 +108,7 @@
(define-public bitcoin-core
(package
(name "bitcoin-core")
- (version "0.19.1")
+ (version "0.20.1")
(source (origin
(method url-fetch)
(uri
@@ -116,11 +116,13 @@
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "1h3w7brc18145np920vy7j5ms5hym59hvr40swdjx34fbdaisngj"))
- (patches (search-patches "bitcoin-core-python-compat.patch"))))
+ "0y5rad68b398arh0abr2wgiwybdw0i5a4dxz9s3fk9fgdbyn5gab"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
("python" ,python) ; for the tests
("util-linux" ,util-linux) ; provides the hexdump command for tests
("qttools" ,qttools)))
@@ -130,7 +132,6 @@
("libevent" ,libevent)
("miniupnpc" ,miniupnpc)
("openssl" ,openssl)
- ("protobuf" ,protobuf)
("qtbase" ,qtbase)))
(arguments
`(#:configure-flags
@@ -154,6 +155,13 @@
;; Make Qt deterministic.
(setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
#t))
+ (add-before 'build 'set-no-git-flag
+ (lambda _
+ ;; Make it clear we are not building from within a git repository
+ ;; (and thus no information regarding this build is available
+ ;; from git).
+ (setenv "BITCOIN_GENBUILD_NO_GIT" "1")
+ #t))
(add-before 'check 'set-home
(lambda _
(setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
diff --git a/gnu/packages/patches/bitcoin-core-python-compat.patch b/gnu/packages/patches/bitcoin-core-python-compat.patch
deleted file mode 100644
index 6bf744124d..0000000000
--- a/gnu/packages/patches/bitcoin-core-python-compat.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Get rid of deprecation warning emitted by Python 3.8, which causes a test failure(!).
-
-https://github.com/bitcoin/bitcoin/pull/17931
-
-Taken from upstream:
-
-https://github.com/bitcoin/bitcoin/commit/f117fb00da747147cddfb071c1427a2754c278cd
-
-diff --git a/test/functional/p2p_invalid_messages.py b/test/functional/p2p_invalid_messages.py
-index 20864881c165..07eacf410d88 100755
---- a/test/functional/p2p_invalid_messages.py
-+++ b/test/functional/p2p_invalid_messages.py
-@@ -145,13 +145,13 @@ def run_test(self):
- def test_magic_bytes(self):
- conn = self.nodes[0].add_p2p_connection(P2PDataStore())
-
-- def swap_magic_bytes():
-+ async def swap_magic_bytes():
- conn._on_data = lambda: None # Need to ignore all incoming messages from now, since they come with "invalid" magic bytes
- conn.magic_bytes = b'\x00\x11\x22\x32'
-
- # Call .result() to block until the atomic swap is complete, otherwise
- # we might run into races later on
-- asyncio.run_coroutine_threadsafe(asyncio.coroutine(swap_magic_bytes)(), NetworkThread.network_event_loop).result()
-+ asyncio.run_coroutine_threadsafe(swap_magic_bytes(), NetworkThread.network_event_loop).result()
-
- with self.nodes[0].assert_debug_log(['PROCESSMESSAGE: INVALID MESSAGESTART ping']):
- conn.send_message(messages.msg_ping(nonce=0xff))