summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lxde.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index fbf32bf337..cad5282e1a 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -137,7 +137,19 @@ able to change themes, icons, and fonts used by GTK+ applications.")
(base32
"04n3vgh3ix12p8jfs4w0dyfq3anbjy33h7g53wbbqqc0f74xyplb"))))
(build-system gnu-build-system)
- (inputs `(("gtk+" ,gtk+-2)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'xrandr-absolutely
+ ;; lxrandr is useless without xrandr and gives an unhelpful error
+ ;; message if it's not in $PATH, so make it a hard dependency.
+ (lambda* (#:key input #:allow-other-keys)
+ (substitute* "src/lxrandr.c"
+ (("(\"|')xrandr\"" _ match)
+ (string-append match (which "xrandr") "\"")))
+ #t)))))
+ (inputs `(("gtk+" ,gtk+-2)
+ ("xrandr" ,xrandr)))
(native-inputs `(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(synopsis "LXDE monitor configuration tool")