summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/simulation.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 9573d4b11c..e5e7d2bf60 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1007,6 +1007,39 @@ implementing motion planning algorithms to solve CommonRoad Benchmarks
and is the basis for other tools of the CommonRoad Framework.")
(license license:bsd-3)))
+(define-public python-commonroad-route-planner
+ (package
+ (name "python-commonroad-route-planner")
+ (version "2022.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.lrz.de/tum-cps/commonroad-route-planner")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xn0l7bzmj56d4mlqacvbl8mdvsffkg2fn2lzfmis5jl4vp99ipf"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-setup.py
+ (lambda _
+ #$%commonroad-dont-install-license-at-root)))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-commonroad-io
+ python-matplotlib
+ python-networkx
+ python-numpy
+ python-setuptools
+ python-shapely))
+ (home-page "https://gitlab.lrz.de/tum-cps/commonroad-route-planner")
+ (synopsis "Route planner for CommonRoad scenarios")
+ (description "This package provides functions for route planning, that is
+finding sequences that lead from a given start lanelet to some goal
+lanelet(s).")
+ (license license:bsd-3)))
+
(define-public sumo
(package
(name "sumo")