summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/code.scm33
-rw-r--r--gnu/packages/indent.scm56
3 files changed, 33 insertions, 57 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 469e73f7c7..4cdbaec1dc 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -226,7 +226,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/image-processing.scm \
%D%/packages/image-viewers.scm \
%D%/packages/imagemagick.scm \
- %D%/packages/indent.scm \
%D%/packages/inklingreader.scm \
%D%/packages/inkscape.scm \
%D%/packages/irc.scm \
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 6dbdf8a232..fc1c000b92 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -9,6 +9,8 @@
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -612,3 +614,34 @@ Objective@tie{}C, D, Java, Pawn, and Vala). Features:
"Artistic Style is a source code indenter, formatter, and beautifier for
the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.")
(license license:lgpl3+)))
+
+(define-public indent
+ (package
+ (name "indent")
+ (version "2.2.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/indent/indent-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (alist-cons-after
+ 'unpack 'fix-docdir
+ (lambda _
+ ;; Although indent uses a modern autoconf in which docdir
+ ;; defaults to PREFIX/share/doc, the doc/Makefile.am
+ ;; overrides this to be in PREFIX/doc. Fix this.
+ (substitute* "doc/Makefile.in"
+ (("^docdir = .*$") "docdir = @docdir@\n")))
+ %standard-phases)))
+ (synopsis "Code reformatter")
+ (description
+ "Indent is a program that makes source code easier to read by
+reformatting it in a consistent style. It can change the style to one of
+several different styles such as GNU, BSD or K&R. It has some flexibility to
+deal with incomplete or malformed syntax. GNU indent offers several
+extensions over the standard utility.")
+ (license license:gpl3+)
+ (home-page "https://www.gnu.org/software/indent/")))
diff --git a/gnu/packages/indent.scm b/gnu/packages/indent.scm
deleted file mode 100644
index 4950a26121..0000000000
--- a/gnu/packages/indent.scm
+++ /dev/null
@@ -1,56 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages indent)
- #:use-module (gnu packages)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public indent
- (package
- (name "indent")
- (version "2.2.10")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/indent/indent-" version
- ".tar.gz"))
- (sha256 (base32
- "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (alist-cons-after
- 'unpack 'fix-docdir
- (lambda _
- ;; Although indent uses a modern autoconf in which docdir
- ;; defaults to PREFIX/share/doc, the doc/Makefile.am
- ;; overrides this to be in PREFIX/doc. Fix this.
- (substitute* "doc/Makefile.in"
- (("^docdir = .*$") "docdir = @docdir@\n")))
- %standard-phases)))
- (synopsis "Code reformatter")
- (description
- "Indent is a program that makes source code easier to read by
-reformatting it in a consistent style. It can change the style to one of
-several different styles such as GNU, BSD or K&R. It has some flexibility to
-deal with incomplete or malformed syntax. GNU indent offers several
-extensions over the standard utility.")
- (license license:gpl3+)
- (home-page "https://www.gnu.org/software/indent/")))