summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/julia.scm10
-rw-r--r--gnu/packages/pcre.scm13
2 files changed, 4 insertions, 19 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index f5bbb5d267..1ede2b0d57 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -457,13 +457,13 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
#t))
(add-after 'unpack 'adjust-test-suite
(lambda* (#:key inputs #:allow-other-keys)
- (let (;(pcre2 (assoc-ref inputs "pcre2"))
+ (let ((pcre2 (assoc-ref inputs "pcre2"))
(mbedtls-apache (assoc-ref inputs "mbedtls"))
(mpfr (assoc-ref inputs "mpfr"))
(suitesparse (assoc-ref inputs "suitesparse")))
;; Some tests only check to see if the input is the correct version.
- ;(substitute* "stdlib/PCRE2_jll/test/runtests.jl"
- ; (("10.36.0") ,(package-version pcre2)))
+ (substitute* "stdlib/PCRE2_jll/test/runtests.jl"
+ (("10.36.0") ,(package-version pcre2)))
(substitute* "stdlib/MbedTLS_jll/test/runtests.jl"
(("2.24.0") ,(package-version mbedtls-apache)))
(substitute* "stdlib/MPFR_jll/test/runtests.jl"
@@ -647,9 +647,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
("openblas" ,openblas)
("openlibm" ,openlibm)
("p7zip" ,p7zip)
- ;; pcre2-10.35 has a bug with the JIT regex parser:
- ;; https://github.com/JuliaLang/julia/issues/40231#issuecomment-812753324
- ("pcre2" ,pcre2-10.36)
+ ("pcre2" ,pcre2)
("suitesparse" ,suitesparse)
("utf8proc" ,utf8proc-2.6.1)
("wget" ,wget)
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 318727915e..7e760c93b1 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -121,16 +121,3 @@ own native API, as well as a set of wrapper functions that correspond to the
POSIX regular expression API.")
(license license:bsd-3)
(home-page "https://www.pcre.org/")))
-
-(define-public pcre2-10.36
- (package
- (inherit pcre2)
- (name "pcre2")
- (version "10.36")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/pcre/pcre2/"
- version "/pcre2-" version ".tar.bz2"))
- (sha256
- (base32
- "0p3699msps07p40g9426lvxa3b41rg7k2fn7qxl2jm0kh4kkkvx9"))))))