summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnucash.scm5
-rw-r--r--gnu/packages/patches/gnucash-fix-test-transaction-failure.patch54
3 files changed, 2 insertions, 58 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9b9c6e00ec..d0c1080496 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -866,7 +866,6 @@ dist_patch_DATA = \
%D%/packages/patches/gmp-faulty-test.patch \
%D%/packages/patches/gnome-shell-theme.patch \
%D%/packages/patches/gnome-tweaks-search-paths.patch \
- %D%/packages/patches/gnucash-fix-test-transaction-failure.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \
%D%/packages/patches/gobject-introspection-absolute-shlib-path.patch \
%D%/packages/patches/gobject-introspection-cc.patch \
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 5b4da97e5d..e09a7cb0c0 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -54,7 +54,7 @@
;; directory.
(package
(name "gnucash")
- (version "3.4")
+ (version "3.5")
(source
(origin
(method url-fetch)
@@ -62,8 +62,7 @@
version "/gnucash-" version ".tar.bz2"))
(sha256
(base32
- "1ms2wg4sh5gq3rpjmmnp85rh5nc9ahca1imxkvhz4d3yiwy8hm52"))
- (patches (search-patches "gnucash-fix-test-transaction-failure.patch"))))
+ "0ibp7g6aknvnkwkin97kv04ipksy3l18dsz9qysjb7h2nr8hnvbp"))))
(build-system cmake-build-system)
(inputs
`(("guile" ,guile-2.2)
diff --git a/gnu/packages/patches/gnucash-fix-test-transaction-failure.patch b/gnu/packages/patches/gnucash-fix-test-transaction-failure.patch
deleted file mode 100644
index 7b1b29f06c..0000000000
--- a/gnu/packages/patches/gnucash-fix-test-transaction-failure.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-# This patch was submitted upstream to: https://bugs.gnucash.org/show_bug.cgi?id=797008.
-From c20d74bebca516d0e391724202aad511967fe109 Mon Sep 17 00:00:00 2001
-From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-Date: Wed, 2 Jan 2019 14:46:28 -0500
-Subject: [PATCH] tests: Fix a test failure in test-transaction.scm.
-
-With the New Year upon us, a test which was hard-coded to use 2018 now
-failed.
-
-Fixes issue #797008 (see:
-https://bugs.gnucash.org/show_bug.cgi?id=797008).
-
-* gnucash/report/standard-reports/test/test-transaction.scm:
-(trep-tests): Use the current year in the test string instead of a
-static one.
----
- gnucash/report/standard-reports/test/test-transaction.scm | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/gnucash/report/standard-reports/test/test-transaction.scm b/gnucash/report/standard-reports/test/test-transaction.scm
-index 755aba298..ae3fbd5c1 100644
---- a/gnucash/report/standard-reports/test/test-transaction.scm
-+++ b/gnucash/report/standard-reports/test/test-transaction.scm
-@@ -5,6 +5,7 @@
- (use-modules (gnucash report stylesheets))
- (use-modules (gnucash report report-system))
- (use-modules (gnucash report report-system test test-extras))
-+(use-modules (srfi srfi-19))
- (use-modules (srfi srfi-64))
- (use-modules (gnucash engine test srfi64-extras))
- (use-modules (sxml simple))
-@@ -643,7 +644,8 @@
- (set-option! options "General" "Show original currency amount" #t)
- (set-option! options "Sorting" "Primary Key" 'date)
- (set-option! options "Sorting" "Primary Subtotal for Date Key" 'none)
-- (let* ((sxml (options->sxml options "dual columns")))
-+ (let* ((sxml (options->sxml options "dual columns"))
-+ (current-year (date->string (current-date) "~y")))
- (test-equal "dual amount column, with original currency headers"
- (list "Date" "Num" "Description" "Memo/Notes" "Account"
- "Debit (USD)" "Credit (USD)" "Debit" "Credit")
-@@ -652,7 +654,8 @@
- (list "Grand Total" "$2,280.00" "$2,280.00")
- (get-row-col sxml -1 #f))
- (test-equal "dual amount column, first transaction correct"
-- (list "01/03/18" "$103 income" "Root.Asset.Bank" "$103.00" "$103.00")
-+ (list (string-append "01/03/" current-year) "$103 income"
-+ "Root.Asset.Bank" "$103.00" "$103.00")
- (get-row-col sxml 1 #f)))
- )
-
---
-2.19.0
-