summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm69
1 files changed, 35 insertions, 34 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 54eeb45940..445d65bc09 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17890,44 +17890,45 @@ using a convenient notation.")
license:fdl1.3+)))) ;GFDLv1.3+ for the manual
(define-public emacs-beframe
- (package
- (name "emacs-beframe")
- (version "1.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/protesilaos/beframe")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "03b5yb2vxcfg2ihiqkl3434rhwn51mr312kzcfhvr4xshgp2g0q5"))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'makeinfo
- (lambda _
- (invoke "emacs"
- "--batch"
- "--eval=(require 'ox-texinfo)"
- "--eval=(find-file \"README.org\")"
- "--eval=(org-texinfo-export-to-info)")
- (install-file "beframe.info"
- (string-append #$output "/share/info")))))))
- (native-inputs
- (list texinfo))
- (home-page "https://protesilaos.com/emacs/beframe")
- (synopsis "Isolate Emacs buffers per frame")
- (description
- "Beframe enables a frame-oriented Emacs workflow where each frame has
+ (let ((commit "c3f4583b0767e7f8c38c83ed29af40af8ba3bdfa")) ;version bump
+ (package
+ (name "emacs-beframe")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/protesilaos/beframe")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j9v85wxahnm2h828c8dbjm0f81j9pxlf54dgcw443cl0kwcda9c"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda _
+ (invoke "emacs"
+ "--batch"
+ "--eval=(require 'ox-texinfo)"
+ "--eval=(find-file \"README.org\")"
+ "--eval=(org-texinfo-export-to-info)")
+ (install-file "beframe.info"
+ (string-append #$output "/share/info")))))))
+ (native-inputs
+ (list texinfo))
+ (home-page "https://protesilaos.com/emacs/beframe")
+ (synopsis "Isolate Emacs buffers per frame")
+ (description
+ "Beframe enables a frame-oriented Emacs workflow where each frame has
access to the list of buffers visited therein. In the interest of brevity, we
call buffers that belong to frames ``beframed''. Producing multiple frames
does not generate multiple buffer lists. There still is only one global list
of buffers. Beframing them simply filters the list.")
- (license (list license:gpl3+
- license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+ (license (list license:gpl3+
+ license:fdl1.3+))))) ; GFDLv1.3+ for the manual
(define-public emacs-gn-mode
(package