summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b0502d8f6f..1e372f6b3b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1331,6 +1331,32 @@ values for the purpose of fuzz testing.")
incoming requests with their respective handler.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-handlers
+ (package
+ (name "go-github-com-gorilla-handlers")
+ (version "1.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/handlers")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15gycdz9lkjnsvvichsbdf25vf6pi1sfn41khhz53iqf300l0w0s"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("github.com/felixge/httpsnoop" ,go-github-com-felixge-httpsnoop)))
+ (arguments
+ '(#:tests? #f ; Tries to download from the internet
+ #:import-path "github.com/gorilla/handlers"))
+ (home-page "https://github.com/gorilla/handlers")
+ (synopsis "Middleware for Go HTTP services and web applications")
+ (description "A collection of useful middleware for Go HTTP services
+and web applications.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jonboulle-clockwork
(let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
(revision "0"))