summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/autotools.scm2
-rw-r--r--gnu/packages/game-development.scm2
-rw-r--r--gnu/packages/gimp.scm4
-rw-r--r--gnu/packages/gnunet.scm2
-rw-r--r--gnu/packages/gnupg.scm2
-rw-r--r--gnu/packages/guile-xyz.scm8
-rw-r--r--gnu/packages/libevent.scm1
-rw-r--r--gnu/packages/logging.scm2
-rw-r--r--gnu/packages/mail.scm2
-rw-r--r--gnu/packages/mate.scm4
-rw-r--r--gnu/packages/package-management.scm2
-rw-r--r--gnu/packages/sawfish.scm2
-rw-r--r--gnu/packages/video.scm2
-rw-r--r--gnu/packages/zile.scm2
14 files changed, 23 insertions, 14 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index e999688894..12a36a4709 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -267,6 +267,8 @@ exec ~a --no-auto-compile \"$0\" \"$@\"
;; Do not show it in the UI since it's meant for internal use.
(properties '((hidden? . #t)))))
+;; Only use this package when autoconf is not usable,
+;; see <https://issues.guix.gnu.org/46564#1>.
(define-public autoconf-wrapper
(make-autoconf-wrapper autoconf))
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 7e17142b9e..6d88c3d73b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -529,7 +529,7 @@ clone.")
all)))
#t))))))
(native-inputs
- `(("autoconf" ,autoconf-wrapper)
+ `(("autoconf" ,autoconf)
("automake" ,automake)
("guile" ,guile-3.0)
("pkg-config" ,pkg-config)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index ddd9158f56..5d005e0378 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -518,6 +518,8 @@ MyPaint.")
(mkdir-p target)
#t))))))
(native-inputs
+ ;; avoid ./autogen.sh: ./configure: /bin/sh: bad interpreter:
+ ;; No such file or directory
`(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("glib" ,glib "bin") ; glib-gettextize
@@ -590,7 +592,7 @@ transferring the style of an image.")
(format port "for dir in '~a'.split(':'):~%" pythonpath)
(format port " site.addsitedir(dir)~%")))))))))
(native-inputs
- `(("autoconf" ,autoconf-wrapper)
+ `(("autoconf" ,autoconf)
("automake" ,automake)
("gtk-doc" ,gtk-doc)
("intltool" ,intltool)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 80e4aba29b..d261f42dcc 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -368,7 +368,7 @@ kinds of basic applications for the foundation of a GNU internet.")
"0nqc18jh9j30y4l6yh6j35byfg6qalq7yr3frv9rk10qa041c2sv"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf-wrapper)
+ ("autoconf" ,autoconf)
("automake" ,automake)))
(inputs `(("guile" ,guile-2.0)
("gnunet" ,gnunet)))
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index f97dd6c4a7..bb611bdb89 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -695,6 +695,8 @@ PGP keysigning parties.")
"1aig5ssabzbk4mih7xd04vgr931bw0flbi8dz902wlr610gyv5s5"))))
(build-system gnu-build-system)
(native-inputs
+ ;; autoconf-wrapper is required due to the non-standard
+ ;; 'configure phase.
`(("autoconf" ,autoconf-wrapper)
("automake" ,automake)))
(inputs `(("perl" ,perl)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2e02f6f482..6493fe6048 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -393,7 +393,7 @@ dictionary and suggesting spelling corrections.")
(string-append "--libdir=" (assoc-ref %outputs "out")
"/lib/bash"))))
(native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf-wrapper)
+ ("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
@@ -660,7 +660,7 @@ is not available for Guile 2.0.")
"1shmkc0y9r2sj3kw7hrsnamnp7y8xifkhf3m3rnfxczqg63k67vy"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf-wrapper)
+ `(("autoconf" ,autoconf)
("automake" ,automake)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
@@ -1723,7 +1723,7 @@ provides tight coupling to Guix.")
#t))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf-wrapper)
+ `(("autoconf" ,autoconf)
("automake" ,automake)
("texinfo" ,texinfo)
;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
@@ -1856,7 +1856,7 @@ users and in some situations.")
"1l6csncjqnx58c6c3wdl7rshnhk4pzhjq2q8lnkg483564s9w5py"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf-wrapper)
+ `(("autoconf" ,autoconf)
("automake" ,automake)
("gettext" ,gettext-minimal)
("libtool" ,libtool)
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index dab574a155..7109d9a88d 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -115,6 +115,7 @@ limited support for fork events.")
'(#:configure-flags '("--disable-static")
;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
#:tests? #f))
+ ;; TODO replace with autoconf on core-updates
(native-inputs `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 87283f3752..eafc23b2e6 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -99,7 +99,7 @@ staying as close to their API as is reasonable.")
#t)))))
(native-inputs
`(("perl" ,perl) ;for tests
- ("autoconf" ,autoconf-wrapper)
+ ("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)))
(synopsis "C++ logging library")
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b02f547e03..239ddb0eb0 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1476,7 +1476,7 @@ useful features.")
(sha256
(base32 "0g7an003simfdn7ihg9yjv7hl2czsmjsndjrp39i7cad8icixscn"))))
(build-system gnu-build-system)
- (native-inputs `(("autoconf" ,autoconf-wrapper)
+ (native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index a9635d90fe..fbb1a74d09 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -176,6 +176,8 @@ actions.")
(setenv "CONFIG_SHELL" (which "sh"))
(invoke "sh" "autogen.sh"))))))
(native-inputs
+ ;; autoconf-wrapper is required due to the non-standard
+ ;; 'autoconf phase.
`(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("intltool" ,intltool)
@@ -1201,7 +1203,7 @@ Re-decorates windows on un-maximise.
(("dbus-1") ""))))))))
(native-inputs
`(("automake" ,automake)
- ("autoconf" ,autoconf-wrapper)
+ ("autoconf" ,autoconf)
("gettext" ,gettext-minimal)
("intltool" ,intltool)
("mate-common" ,mate-common)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 49067850c1..6a7285f33e 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -379,7 +379,7 @@ $(prefix)/etc/init.d\n")))
;; XXX: Keep the development inputs here even though
;; they're unnecessary, just so that 'guix environment
;; guix' always contains them.
- ("autoconf" ,autoconf-wrapper)
+ ("autoconf" ,autoconf)
("automake" ,automake)
("gettext" ,gettext-minimal)
("texinfo" ,texinfo)
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index 26d8eba3b6..4162fe43cd 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -53,7 +53,7 @@
`(("makeinfo" ,texinfo)
("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf-wrapper)
+ ("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)))
(inputs
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index eb1c329c1b..dbe042c0d9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4265,7 +4265,7 @@ It counts more than 100 plugins.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf-wrapper)
+ `(("autoconf" ,autoconf)
("automake" ,automake)
("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/zile.scm b/gnu/packages/zile.scm
index 6169815520..c28bc1bdd1 100644
--- a/gnu/packages/zile.scm
+++ b/gnu/packages/zile.scm
@@ -120,7 +120,7 @@ default Emacs configuration, but it carries a much lighter feature set.")
,@(package-inputs zile)))
(native-inputs
`(("m4" ,m4) ;for 'bootstrap'
- ("autoconf" ,autoconf-wrapper)
+ ("autoconf" ,autoconf)
("automake" ,automake)
;; For some reason, 'bootstrap' insists on having these.