summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 548481965e..7df24dda5d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24012,15 +24012,15 @@ targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
"1zr9lczdr9dfh99n079d5advxm9p32a8f984dx14f3jn5mx750b1"))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #t
- #:test-command '("make" "test")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-bin
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "bin/buttercup"
- (string-append (assoc-ref outputs "out") "/bin"))
- #t)))))
+ (list
+ #:tests? #t
+ #:test-command #~(list "make" "test")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-bin
+ (lambda _
+ (install-file "bin/buttercup"
+ (string-append #$output "/bin")))))))
(home-page "https://github.com/jorgenschaefer/emacs-buttercup")
(synopsis "Behavior driven emacs lisp testing framework")
(description "Buttercup is a behavior-driven development framework for