summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/wgetpaste-update-bpaste.patch27
-rw-r--r--gnu/packages/wget.scm5
3 files changed, 2 insertions, 31 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 870769cffc..1c692e0ce4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1805,7 +1805,6 @@ dist_patch_DATA = \
%D%/packages/patches/webkitgtk-share-store.patch \
%D%/packages/patches/webkitgtk-bind-all-fonts.patch \
%D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch \
- %D%/packages/patches/wgetpaste-update-bpaste.patch \
%D%/packages/patches/wicd-bitrate-none-fix.patch \
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
%D%/packages/patches/wicd-urwid-1.3.patch \
diff --git a/gnu/packages/patches/wgetpaste-update-bpaste.patch b/gnu/packages/patches/wgetpaste-update-bpaste.patch
deleted file mode 100644
index f92a0c17ed..0000000000
--- a/gnu/packages/patches/wgetpaste-update-bpaste.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Tue, 01 Sep 2020 04:23:25 +0200
-Subject: [PATCH] Update bpaste URL & regular expressions.
-
-diff -Naur wgetpaste-2.30/wgetpaste wgetpaste-2.30a/wgetpaste
---- wgetpaste-2.30/wgetpaste 2020-07-31 23:56:05.000000000 +0200
-+++ wgetpaste-2.30a/wgetpaste 2020-09-01 04:22:37.499898403 +0200
-@@ -16,7 +16,7 @@
- SERVICES="codepad bpaste dpaste gists snippets"
- # bpaste
- ENGINE_bpaste=pinnwand
--URL_bpaste="https://bpaste.net/"
-+URL_bpaste="https://bpa.st/"
- DEFAULT_EXPIRATION_bpaste="1week"
- DEFAULT_LANGUAGE_bpaste="text"
- # codepad
-@@ -194,8 +194,8 @@
- xml+velocity xml xquery xslt xtend yaml"
- EXPIRATIONS_pinnwand="1day 1week 1month never"
- POST_pinnwand="submit=Paste! % % lexer expiry % code"
--REGEX_LOC_pinnwand="\(/show/[^ ]*\).*$|https://bpaste.net\1"
--REGEX_RAW_pinnwand='s|^\(https\?://[^/]*/\)show\(/[^ ]*/\?\)$|\1raw\2|'
-+REGEX_LOC_pinnwand="\(/[^ ]*\).*$|https://bpa.st\1"
-+REGEX_RAW_pinnwand='s|^\(https\?://[^/]*\)\(/[^ ]*/\?\)$|\1/raw\2|'
-
- ### errors
- die() {
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 3d7f266dd7..8891170e10 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -78,7 +78,7 @@ in downloaded documents to relative links.")
(define-public wgetpaste
(package
(name "wgetpaste")
- (version "2.30")
+ (version "2.32")
(source
(origin
(method git-fetch)
@@ -87,8 +87,7 @@ in downloaded documents to relative links.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0fhm0qxdsm4k1m24z4bbb7mdv1x1iaqzgsnwkax6vb8bx9yd1ysi"))
- (patches (search-patches "wgetpaste-update-bpaste.patch"))))
+ (base32 "13zdqfnbpymwz2f04icw92flj50227n5r0dcms84qxswfxrarnas"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)