summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a7941187d1..2926c1c4c9 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +47,7 @@
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
#:use-module (gnu packages flex)
@@ -79,6 +81,7 @@
#:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages texlive)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml)
#:use-module (gnu packages zip)
@@ -583,7 +586,7 @@ online as well as original implementations of various other algorithms.")
(define-public octave
(package
(name "octave")
- (version "4.0.0")
+ (version "4.0.2")
(source
(origin
(method url-fetch)
@@ -591,7 +594,7 @@ online as well as original implementations of various other algorithms.")
version ".tar.gz"))
(sha256
(base32
- "101jr9yck798586jz4vkjcgk36zksmxf1pxrzvipgn2xgyay0zjc"))))
+ "1hdxap3j88rpqjimnfhinym6z73wdi5dfa6fv85c13r1dk9qzk9r"))))
(build-system gnu-build-system)
(inputs
`(("lapack" ,lapack)
@@ -602,6 +605,7 @@ online as well as original implementations of various other algorithms.")
("arpack" ,arpack-ng)
("curl" ,curl)
("pcre" ,pcre)
+ ("cyrus-sasl" ,cyrus-sasl)
("fltk" ,fltk)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
@@ -609,6 +613,7 @@ online as well as original implementations of various other algorithms.")
("libxft" ,libxft)
("mesa" ,mesa)
("glu" ,glu)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(native-inputs
`(("gfortran" ,gfortran)
@@ -626,9 +631,10 @@ online as well as original implementations of various other algorithms.")
("ghostscript" ,ghostscript)
("gnuplot" ,gnuplot)))
(arguments
- `(#:configure-flags (list (string-append "--with-shell="
- (assoc-ref %build-inputs "bash")
- "/bin/sh"))))
+ `(#:configure-flags
+ (list (string-append "--with-shell="
+ (assoc-ref %build-inputs "bash")
+ "/bin/sh"))))
(home-page "http://www.gnu.org/software/octave/")
(synopsis "High-level language for numerical computation")
(description "GNU Octave is a high-level interpreted language that is