summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 9f5bedd913..026ce92aab 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -1045,6 +1047,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("unixodbc" ,unixodbc)
("unzip" ,unzip)
("vigra" ,vigra)
+ ("xdg-utils" ,xdg-utils)
("xmlsec" ,xmlsec-nss)
("zip" ,zip)))
(arguments
@@ -1077,6 +1080,13 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(assoc-ref inputs "gpgme")
"/include/gpgme++")))
+ ;; /usr/bin/xdg-open doesn't exist on Guix System.
+ (substitute* '("shell/source/unix/exec/shellexec.cxx"
+ "shell/source/unix/misc/senddoc.sh")
+ (("/usr/bin/xdg-open")
+ (string-append (assoc-ref inputs "xdg-utils")
+ "/bin/xdg-open")))
+
#t))
(add-after 'install 'bin-and-desktop-install
;; Create 'soffice' and 'libreoffice' symlinks to the executable