summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm34
-rw-r--r--gnu/packages/web.scm1
2 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 161c9967e2..44fe95479f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4393,3 +4393,37 @@ Agent is a web crawler. It uses the list of registered robots from
"This module provides an interface that queries the Apache Solr server
using a pure Python implementation.")
(license license:bsd-3)))
+
+(define-public python-http-ece
+ (package
+ (name "python-http-ece")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/web-push-libs/encrypted-content-encoding")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bp4cc0xc123i72h80ax3qz3ixfwx3j7pw343kc7i6kdvfi8klx7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _ (chdir "python") #t)))))
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-flake8" ,python-flake8)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/web-push-libs/encrypted-content-encoding")
+ (synopsis "Encrypted Content Encoding for HTTP")
+ (description
+ "This package provices a simple implementation of Encrypted Content
+Encoding for HTTP.")
+ (license license:expat)))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7107c9e0bc..f40ff911e2 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -136,6 +136,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages pcre)