summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm2
-rw-r--r--gnu/packages/documentation.scm4
-rw-r--r--gnu/packages/ebook.scm2
-rw-r--r--gnu/packages/education.scm10
-rw-r--r--gnu/packages/emacs-xyz.scm2
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/fcitx5.scm2
-rw-r--r--gnu/packages/geo.scm2
-rw-r--r--gnu/packages/image-viewers.scm2
-rw-r--r--gnu/packages/jami.scm2
-rw-r--r--gnu/packages/kde-pim.scm12
-rw-r--r--gnu/packages/kde.scm6
-rw-r--r--gnu/packages/messaging.scm2
-rw-r--r--gnu/packages/qt.scm14
-rw-r--r--gnu/packages/sync.scm2
-rw-r--r--gnu/packages/text-editors.scm2
-rw-r--r--gnu/packages/vpn.scm4
-rw-r--r--gnu/packages/web-browsers.scm8
-rw-r--r--gnu/packages/web.scm4
19 files changed, 42 insertions, 42 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e3ee3dbfb7..f0ffeed210 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3237,7 +3237,7 @@ link REQUIRED)"))))))
qtwebchannel-5
qtwebsockets-5))
(propagated-inputs ;to get native-search-path
- (list qtwebengine))
+ (list qtwebengine-5))
(home-page "https://github.com/supercollider/supercollider")
(synopsis "Synthesis engine and programming language")
(description "SuperCollider is a synthesis engine (@code{scsynth} or
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 32dc26868d..6f24149b5d 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -371,7 +371,7 @@ local system.")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/zeal"))
(qt-process-path (string-append
- (assoc-ref inputs "qtwebengine")
+ (assoc-ref inputs "qtwebengine-5")
"/lib/qt5/libexec/QtWebEngineProcess")))
(wrap-program bin
`("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
@@ -384,7 +384,7 @@ local system.")
("qtbase" ,qtbase-5)
("qtdeclarative-5" ,qtdeclarative-5)
("qtwebchannel-5" ,qtwebchannel-5)
- ("qtwebengine" ,qtwebengine)
+ ("qtwebengine-5" ,qtwebengine-5)
("qtquickcontrols-5" ,qtquickcontrols-5)
("qtx11extras" ,qtx11extras)
("xcb-util-keyms" ,xcb-util-keysyms)))
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 5d864da281..ccc0bdf88d 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -202,7 +202,7 @@ with Microsoft Compiled HTML (CHM) files")
python-regex
speech-dispatcher
python-zeroconf
- qtwebengine
+ qtwebengine-5
sqlite))
(arguments
(list
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 5551fd0594..aabf3dfc21 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -448,7 +448,7 @@ specialized device.")
(define-public openboard
;; The last release builds from qtwebkit, which is planned for removal in
;; Guix, so use the latest commit of the 1.7-dev branch, which builds with
- ;; qtwebengine.
+ ;; qtwebengine-5.
(let ((commit "39e914f600d26565706f0e5b6ea2482b8b4038c7") ;1.6.2-rc0311
(revision "1"))
(package
@@ -562,7 +562,7 @@ specialized device.")
qtmultimedia-5
qtsvg-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
qtxmlpatterns
quazip-0
sdl
@@ -807,9 +807,9 @@ stored and user can review his performance in any time.")
("python-requests" ,python-requests)
("python-send2trash" ,python-send2trash)
("python-sip" ,python-sip)
- ;; `qtwebengine' is included in `pyqtwebengine', included here for easy
+ ;; `qtwebengine-5' is included in `pyqtwebengine', included here for easy
;; wrapping.
- ("qtwebengine" ,qtwebengine)))
+ ("qtwebengine-5" ,qtwebengine-5)))
(home-page "https://apps.ankiweb.net/")
(synopsis "Powerful, intelligent flash cards")
(description "Anki is a program which makes remembering things
@@ -999,7 +999,7 @@ formats.")
qtquickcontrols2-5
qtdeclarative-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
zlib))
(synopsis "EPWING dictionary reader")
(description "qolibri is a dictionary viewer for the EPWING dictionary
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 217e90b8fb..3804ef402a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13111,7 +13111,7 @@ programming and reproducible research.")
(sha256
(base32 "17aca4mc3gbdh6nhlcaa5ymh1yy76nwysrvy9sfcqkzvd5lgagzc"))
;; XXX: ob-sclang.el is packaged separately to avoid the dependency on
- ;; SuperCollider and qtwebengine. This will be unnecessary in 0.4+
+ ;; SuperCollider and qtwebengine-5. This will be unnecessary in 0.4+
;; release as the file is going to be removed from the repository.
;; XXX: org-contacts.el is now maintained in a separate repository and
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c8d075f5d1..303dd0b737 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2493,7 +2493,7 @@ comments.")))
qtdeclarative-5
qtsvg-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
qtx11extras
qtxmlpatterns
sqlite
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index ea7f1be752..00648ea963 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -394,7 +394,7 @@ the Anthy input method.")
("fcitx5-qt" ,fcitx5-qt)
("qtdeclarative-5" ,qtdeclarative-5)
("qtwebchannel-5" ,qtwebchannel-5)
- ("qtwebengine" ,qtwebengine)))
+ ("qtwebengine-5" ,qtwebengine-5)))
(native-inputs
(list extra-cmake-modules pkg-config))
(outputs '("out" "gui"))
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 324178181c..b8125ffe6e 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1961,7 +1961,7 @@ using the dataset of topographical information collected by
qtdeclarative-5
qtlocation
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
quazip
routino
sqlite ; See wrap phase
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 81b097df07..045fdae882 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -531,7 +531,7 @@ It supports JPEG, PNG and GIF formats.")
libjpeg-turbo
lcms
openexr-2
- qtwebengine
+ qtwebengine-5
qtdeclarative-5
qtwebchannel-5
fftwf
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 2583a59a26..22d2f0c5ce 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -605,7 +605,7 @@ decentralized calling using P2P-DHT.")
network-manager
qrencode
qtsvg-5
- qtwebengine
+ qtwebengine-5
qtwebchannel-5
qtmultimedia-5
qtdeclarative-5
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index b78c4b8c45..f0f5683ac5 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -728,7 +728,7 @@ for KDE PIM.")
qtnetworkauth
qtspeech
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
qtxmlpatterns))
(arguments
;; TODO: 5/45 tests fail for quite different reasons, even with
@@ -1072,7 +1072,7 @@ and retrieving certificates from LDAP servers.")
qtbase-5
qtdeclarative-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
sonnet))
(arguments
`(#:phases
@@ -1324,7 +1324,7 @@ using a Qt/KMime C++ API.")
qtbase-5
qtdeclarative-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
qtwebkit
sonnet))
(arguments
@@ -1656,7 +1656,7 @@ Virtual Contact File}) files to the KPeople contact management library.")
libxslt
purpose
qtbase-5
- qtwebengine))
+ qtwebengine-5))
(arguments
`(#:tests? #f)) ;; TODO tests hang
(home-page "https://invent.kde.org/pim/pimcommon")
@@ -1850,7 +1850,7 @@ and allows one to view/extract message formatted text in Rich Text Format.")
qtbase-5
qtdeclarative-5
qtwebchannel-5
- qtwebengine))
+ qtwebengine-5))
(arguments
`(#:tests? #f)) ;; TODO 6/48 tests fail
(home-page "https://invent.kde.org/pim/libkgapi")
@@ -1933,7 +1933,7 @@ KDE using certificate-based crypto.")
qtbase-5
qtdeclarative-5
qtwebchannel-5
- qtwebengine))
+ qtwebengine-5))
(arguments
`(#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 6e9d9d125f..c43758ef7f 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -170,7 +170,7 @@ This package contains GUI widgets for baloo.")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/akregator"))
(qt-process-path (string-append
- (assoc-ref inputs "qtwebengine")
+ (assoc-ref inputs "qtwebengine-5")
"/lib/qt5/libexec/QtWebEngineProcess")))
(wrap-program bin
`("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
@@ -207,7 +207,7 @@ This package contains GUI widgets for baloo.")
qtbase-5
qtdeclarative-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
syndication))
(home-page "https://apps.kde.org/en/akregator")
(synopsis "KDE Feed Reader")
@@ -1029,7 +1029,7 @@ Python, PHP, and Perl.")
qtserialport
qtsvg-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
shapelib
shared-mime-info
zlib))
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 034648d02c..e5dd078561 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2913,7 +2913,7 @@ as phones, embedded computers or microcontrollers.")
(inputs
(list qtbase-5 qtdeclarative-5 qtwebchannel-5))
(propagated-inputs
- (list qtwebengine))
+ (list qtwebengine-5))
(home-page "https://movim.eu/")
(synopsis "Desktop Application for Movim")
(description
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 3f1f468b7e..3450efe08b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2011,7 +2011,7 @@ using the Enchant spell-checking library.")
;; COPYING file specify GPL3, but source code files all refer to GPL2+.
(license license:gpl2+)))
-(define-public qtwebengine
+(define-public qtwebengine-5
(package
(inherit qtsvg-5)
(name "qtwebengine")
@@ -2206,7 +2206,7 @@ using the Enchant spell-checking library.")
(_ #t)))
(with-directory-excursion "src/3rdparty"
- ;; TODO: Try removing "gn" too for future versions of qtwebengine.
+ ;; TODO: Try removing "gn" too for future versions of qtwebengine-5.
(delete-file-recursively "ninja")
(with-directory-excursion "chromium"
@@ -2324,7 +2324,7 @@ using the Enchant spell-checking library.")
(display "\ngn_args += use_system_openh264=true\n" out)))
;; Qtwebengine is not installed into the same prefix as
;; qtbase. Some qtbase QTLibraryInfo constants will not
- ;; work. Replace with the full path to the qtwebengine
+ ;; work. Replace with the full path to the qtwebengine-5
;; translations and locales in the store.
(substitute* "src/core/web_engine_library_info.cpp"
(("QLibraryInfo::location\\(QLibraryInfo::TranslationsPath\\)")
@@ -2354,7 +2354,7 @@ using the Enchant spell-checking library.")
(invoke "qmake" "QT_BUILD_PARTS = libs tools" "--"
"--webengine-printing-and-pdf=no"
"--webengine-ffmpeg=system"
- ;; FIXME: Building qtwebengine 5.12.2 with
+ ;; FIXME: Building qtwebengine-5 5.12.2 with
;; icu4c >= 68 fails.
;;"--webengine-icu=system"
"--webengine-pepper-plugins=no"
@@ -2647,7 +2647,7 @@ contain over 620 classes.")
("qtsvg-5" ,qtsvg-5)
("qtdeclarative-5" ,qtdeclarative-5)
("qtwebchannel-5" ,qtwebchannel-5)
- ("qtwebengine" ,qtwebengine)))
+ ("qtwebengine-5" ,qtwebengine-5)))
(arguments
`(#:modules ((srfi srfi-1)
((guix build python-build-system) #:select (python-version))
@@ -3358,7 +3358,7 @@ color-related widgets.")
qtspeech
qtsvg-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
qtwebsockets-5
qtx11extras
qtxmlpatterns))
@@ -3408,7 +3408,7 @@ color-related widgets.")
"qtsvg-5"
"qttools"
"qtwebchannel-5"
- "qtwebengine"
+ "qtwebengine-5"
"qtwebsockets-5"
"qtx11extras"
"qtxmlpatterns"))))
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 10aef0c83a..5b82e0ca3d 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -201,7 +201,7 @@
xdg-utils
zlib))
(propagated-inputs
- (list qtwebengine))
+ (list qtwebengine-5))
(synopsis "Desktop sync client for Nextcloud")
(description "Nextcloud-Desktop is a tool to synchronize files from
Nextcloud Server with your computer.")
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index acf0400b75..345454bd62 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -673,7 +673,7 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
qtsvg-5
qtwebchannel-5))
(propagated-inputs ; To get native-search-path
- (list qtwebengine))
+ (list qtwebengine-5))
(arguments
`(#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index a884feabf4..17dd163c53 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -737,7 +737,7 @@ and probably others.")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/openconnect-sso"))
(qt-process-path (string-append
- (assoc-ref inputs "qtwebengine")
+ (assoc-ref inputs "qtwebengine-5")
"/lib/qt5/libexec/QtWebEngineProcess")))
(wrap-program bin
#:sh (search-input-file inputs "bin/bash")
@@ -757,7 +757,7 @@ and probably others.")
python-pyxdg
python-structlog
python-toml
- qtwebengine))
+ qtwebengine-5))
(native-inputs
(list python-pytest python-setuptools-scm))
(home-page "https://github.com/vlaci/openconnect-sso")
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 751478c3d1..f47db2e752 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -492,11 +492,11 @@ interface.")
;; that it's __init__.py is used first.
python-pyqtwebengine
python-pyqt-without-qtwebkit
- ;; While qtwebengine is provided by python-pyqtwebengine, it's
+ ;; While qtwebengine-5 is provided by python-pyqtwebengine, it's
;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
- qtwebengine))
+ qtwebengine-5))
(arguments
- `(;; FIXME: With the existance of qtwebengine, tests can now run. But
+ `(;; FIXME: With the existance of qtwebengine-5, tests can now run. But
;; they are still disabled because test phase hangs. It's not readily
;; apparent as to why.
#:tests? #f
@@ -543,7 +543,7 @@ interface.")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/qutebrowser"))
(qt-process-path (string-append
- (assoc-ref inputs "qtwebengine")
+ (assoc-ref inputs "qtwebengine-5")
"/lib/qt5/libexec/QtWebEngineProcess")))
(wrap-program bin
`("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))))))))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f6c618478f..8b41477014 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8078,7 +8078,7 @@ It contains the code shared by all Kiwix ports.")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/kiwix-desktop"))
(qt-process-path (string-append
- (assoc-ref inputs "qtwebengine")
+ (assoc-ref inputs "qtwebengine-5")
"/lib/qt5/libexec/QtWebEngineProcess")))
(wrap-program bin
`("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
@@ -8093,7 +8093,7 @@ It contains the code shared by all Kiwix ports.")
qtbase-5
qtdeclarative-5
qtwebchannel-5
- qtwebengine
+ qtwebengine-5
xapian
zlib
`(,zstd "lib")))