summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 45a105ba11..99ad2b421c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5127,9 +5127,10 @@ disks and SD cards. This package provides the userland utilities.")
(let ((libuuid-static (assoc-ref %build-inputs "libuuid:static"))
(libuuid (assoc-ref %build-inputs "libuuid")))
(list
- (string-append "libuuid_CFLAGS=-I" libuuid "/include")
+ (string-append "libuuid_CFLAGS=-I" libuuid "/include/uuid")
(string-append "libuuid_LIBS=-L" libuuid-static "/lib -luuid")
- (string-append "libblkid_CFLAGS=-I" libuuid "/include")
+ (string-append "libblkid_CFLAGS=-I" libuuid "/include/uuid "
+ "-I" libuuid "/include/blkid")
(string-append "libblkid_LIBS=-L" libuuid-static "/lib -lblkid")))
#:disallowed-references (,util-linux)
#:phases