summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 860eb5fe82..909943fb14 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9786,3 +9786,29 @@ perform regression test for packages that provide font-lock rules.")
@item Thorough font-lock and indent.
@end itemize\n")
(license license:gpl3+))))
+
+(define-public emacs-grep-context
+ (let ((commit "a17c57e66687a54e195e08afe776bdd60cb6c0a7"))
+ (package
+ (name "emacs-grep-context")
+ (version (git-version "0.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mkcms/grep-context.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1nqfa6kjzjshww4hnwg1c0vcr90bdjihy3kmixq3c3jkvxg99b62"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/nashamri/academic-phrases")
+ (synopsis "Increase context in compilation and grep buffers")
+ (description
+ "This package provides an Emacs package for more context in
+compilation/grep buffers. Works with @code{wgrep}, @code{ack}, @code{ag},
+@code{ivy}.")
+ (license license:gpl3+))))