summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mpi.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index f51e03a4d7..116fa1ebb0 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -52,7 +52,7 @@
#:use-module (srfi srfi-1)
#:use-module (ice-9 match))
-(define-public hwloc
+(define-public hwloc-1
;; Note: For now we keep 1.x as the default because many packages have yet
;; to migrate to 2.0.
(package
@@ -134,7 +134,7 @@ bind processes, and much more.")
(define-public hwloc-2
;; Note: 2.0 isn't the default yet, see above.
(package
- (inherit hwloc)
+ (inherit hwloc-1)
(version "2.1.0")
(source (origin
(method url-fetch)
@@ -163,6 +163,10 @@ bind processes, and much more.")
(define-deprecated hwloc-2.0 'hwloc-2
hwloc-2)
+(define-public hwloc
+ ;; The latest stable series of hwloc.
+ hwloc-2)
+
(define-public openmpi
(package
(name "openmpi")