summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/dns.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 86185373c4..a0388a1419 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -625,6 +625,7 @@ to result in system-wide compromise.")
(inputs
`(("expat" ,expat)
("libevent" ,libevent)
+ ("nghttp2" ,nghttp2 "lib")
("protobuf" ,protobuf)
("python-wrapper" ,python-wrapper)
("openssl" ,openssl)))
@@ -632,6 +633,8 @@ to result in system-wide compromise.")
`(#:configure-flags
(list "--disable-static" ; save space and non-determinism in libunbound.a
(string-append
+ "--with-libnghttp2=" (assoc-ref %build-inputs "nghttp2"))
+ (string-append
"--with-ssl=" (assoc-ref %build-inputs "openssl"))
(string-append
"--with-libevent=" (assoc-ref %build-inputs "libevent"))