summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cpp.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 12e766761f..3981f962d7 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -28,6 +28,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages check)
@@ -350,3 +351,27 @@ tools:
@item CPU checker.
@end itemize\n")
(license license:bsd-3)))
+
+(define-public cpplint
+ (package
+ (name "cpplint")
+ (version "1.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ ;; Fetch from github instead of pypi, since the test cases are not in
+ ;; the pypi archive.
+ (uri (git-reference
+ (url "https://github.com/cpplint/cpplint")
+ (commit version)))
+ (sha256
+ (base32 "1ns9wbizr10w7rpyp106d7ip68s5nyskr54vw9bij11sci9z0v3j"))
+ (file-name (git-file-name name version))))
+ (build-system python-build-system)
+ (home-page "https://github.com/cpplint/cpplint")
+ (synopsis "Static code checker for C++")
+ (description "@code{cpplint} is a command-line tool to check C/C++ files
+for style issues following Google’s C++ style guide. While Google maintains
+it's own version of the tool, this is a fork that aims to be more responsive
+and make @code{cpplint} usable in wider contexts.")
+ (license license:bsd-3)))