summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm41
-rw-r--r--gnu/packages/statistics.scm40
2 files changed, 41 insertions, 40 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a6e0c5a1e6..2e0f457321 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -722,6 +722,47 @@ the weighted combination of published signatures that, when summed, most
closely reconstructs the mutational profile.")
(license license:gpl2+)))
+;; This is a CRAN package, but it depends on Bioconductor packages.
+(define-public r-nmf
+ (package
+ (name "r-nmf")
+ (version "0.21.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "NMF" version))
+ (sha256
+ (base32
+ "1qq25n3k5sgh3srlshb3ic6q92s12c1ilqf5cd5anvq6cqfchc1v"))))
+ (properties `((upstream-name . "NMF")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)
+ ("r-bigmemory" ,r-bigmemory) ; suggested
+ ("r-synchronicity" ,r-synchronicity) ; suggested
+ ("r-colorspace" ,r-colorspace)
+ ("r-digest" ,r-digest)
+ ("r-doparallel" ,r-doparallel)
+ ("r-foreach" ,r-foreach)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridbase" ,r-gridbase)
+ ("r-pkgmaker" ,r-pkgmaker)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-registry" ,r-registry)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rngtools" ,r-rngtools)
+ ("r-stringr" ,r-stringr)))
+ (home-page "http://renozao.github.io/NMF")
+ (synopsis "Algorithms and framework for nonnegative matrix factorization")
+ (description
+ "This package provides a framework to perform Non-negative Matrix
+Factorization (NMF). The package implements a set of already published
+algorithms and seeding methods, and provides a framework to test, develop and
+plug new or custom algorithms. Most of the built-in algorithms have been
+optimized in C++, and the main interface function provides an easy way of
+performing parallel computations on multicore machines.")
+ (license license:gpl2+)))
+
(define-public r-do-db
(package
(name "r-do-db")
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 313634c29c..4b1b34cd3b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3420,46 +3420,6 @@ memory-mapped files.")
;; Users can choose either LGPLv3 or ASL2.0.
(license (list license:lgpl3 license:asl2.0))))
-(define-public r-nmf
- (package
- (name "r-nmf")
- (version "0.21.0")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "NMF" version))
- (sha256
- (base32
- "1qq25n3k5sgh3srlshb3ic6q92s12c1ilqf5cd5anvq6cqfchc1v"))))
- (properties `((upstream-name . "NMF")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-cluster" ,r-cluster)
- ("r-bigmemory" ,r-bigmemory) ; suggested
- ("r-synchronicity" ,r-synchronicity) ; suggested
- ("r-colorspace" ,r-colorspace)
- ("r-digest" ,r-digest)
- ("r-doparallel" ,r-doparallel)
- ("r-foreach" ,r-foreach)
- ("r-ggplot2" ,r-ggplot2)
- ("r-gridbase" ,r-gridbase)
- ("r-pkgmaker" ,r-pkgmaker)
- ("r-rcolorbrewer" ,r-rcolorbrewer)
- ("r-registry" ,r-registry)
- ("r-reshape2" ,r-reshape2)
- ("r-rngtools" ,r-rngtools)
- ("r-stringr" ,r-stringr)))
- (home-page "http://renozao.github.io/NMF")
- (synopsis "Algorithms and framework for nonnegative matrix factorization")
- (description
- "This package provides a framework to perform Non-negative Matrix
-Factorization (NMF). The package implements a set of already published
-algorithms and seeding methods, and provides a framework to test, develop and
-plug new or custom algorithms. Most of the built-in algorithms have been
-optimized in C++, and the main interface function provides an easy way of
-performing parallel computations on multicore machines.")
- (license license:gpl2+)))
-
(define-public r-r-methodss3
(package
(name "r-r-methodss3")