summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gcc.scm5
-rw-r--r--gnu/packages/storage.scm2
2 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index fb06b53474..1f1e80dde8 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -490,16 +490,15 @@ Go. It also includes runtime support libraries for these languages.")
(define-public gcc-7
(package
(inherit gcc-6)
- (version "7.3.0")
+ (version "7.4.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gcc/gcc-"
version "/gcc-" version ".tar.xz"))
(sha256
(base32
- "0p71bij6bfhzyrs8676a8jmpjsfz392s2rg862sdnsk30jpacb43"))
+ "0lgy170b0pp60j9cczqkmaqyjjb584vfamj4c30swd7k0j6y5pgd"))
(patches (search-patches "gcc-strmov-store-file-names.patch"
- "gcc-libsanitizer-ustat.patch"
"gcc-5.0-libvtv-runpath.patch"))))
(description
"GCC is the GNU Compiler Collection. It provides compiler front-ends
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 5051ccd986..4eae37815e 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -321,7 +321,7 @@
("python2-testtools" ,python2-testtools)
("python2-tox" ,python2-tox)))
(inputs
- `(("boost" ,boost)
+ `(("boost" ,boost-cxx14)
("curl" ,curl)
("cryptsetup" ,cryptsetup)
("expat" ,expat)