summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 74aee4a3c2..38b35ee9bf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7631,24 +7631,35 @@ computing.")
(define-public python-urwid
(package
(name "python-urwid")
- (version "2.1.0")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "urwid" version))
(sha256
(base32
- "11ndnhxd41m13darf5s0c6bafdpkzq1l6mfb04wbzdmyc1hg75h8"))))
+ "1bky2bra6673xx8jy0826znw6cmxs89wcwwzda8d025j3jffx2sq"))))
(build-system python-build-system)
(home-page "http://urwid.org")
(synopsis "Console user interface library for Python")
(description
"Urwid is a curses-based UI/widget library for Python. It includes many
features useful for text console applications.")
+ (properties `((python2-variant . ,(delay python2-urwid))))
(license license:lgpl2.1+)))
(define-public python2-urwid
- (package-with-python2 python-urwid))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-urwid))))
+ (package/inherit base
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urwid" version))
+ (sha256
+ (base32
+ "11ndnhxd41m13darf5s0c6bafdpkzq1l6mfb04wbzdmyc1hg75h8")))))))
(define-public python-urwidtrees
(package