summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/version-control.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 36dbce4688..4aac1fc2fb 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1106,23 +1106,21 @@ following features:
(lambda* (#:key outputs #:allow-other-keys)
;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.
(let ((out (assoc-ref outputs "out")))
- (and (zero? (system* "make" "swig-pl-lib"))
- ;; FIXME: Test failures.
- ;; (zero? (system* "make" "check-swig-pl"))
- (zero? (system* "make" "install-swig-pl-lib"))
-
- ;; Set the right installation prefix.
- (with-directory-excursion
- "subversion/bindings/swig/perl/native"
- (and (zero?
- (system* "perl" "Makefile.PL"
- "NO_PERLLOCAL=1"
- (string-append "PREFIX=" out)))
- (zero?
- (system* "make" "install"
- (string-append "OTHERLDFLAGS="
- "-Wl,-rpath="
- out "/lib"))))))))))))
+ (invoke "make" "swig-pl-lib")
+ ;; FIXME: Test failures.
+ ;; (invoke "make" "check-swig-pl")
+ (invoke "make" "install-swig-pl-lib")
+
+ ;; Set the right installation prefix.
+ (with-directory-excursion
+ "subversion/bindings/swig/perl/native"
+ (invoke "perl" "Makefile.PL"
+ "NO_PERLLOCAL=1"
+ (string-append "PREFIX=" out))
+ (invoke "make" "install"
+ (string-append "OTHERLDFLAGS="
+ "-Wl,-rpath="
+ out "/lib")))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
;; For the Perl bindings.