summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gpodder.scm7
-rw-r--r--gnu/packages/patches/gpodder-disable-updater.patch18
3 files changed, 23 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3b97b8fdf3..b059dedfe3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1074,6 +1074,7 @@ dist_patch_DATA = \
%D%/packages/patches/gobject-introspection-girepository.patch \
%D%/packages/patches/go-skip-gc-test.patch \
%D%/packages/patches/gpm-glibc-2.26.patch \
+ %D%/packages/patches/gpodder-disable-updater.patch \
%D%/packages/patches/gpsbabel-minizip.patch \
%D%/packages/patches/gpsbabel-qstring.patch \
%D%/packages/patches/grantlee-merge-theme-dirs.patch \
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 734599483b..26ea15ba56 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -38,7 +38,7 @@
(define-public gpodder
(package
(name "gpodder")
- (version "3.10.15")
+ (version "3.10.16")
(source
(origin
(method git-fetch)
@@ -47,8 +47,9 @@
(commit version)))
(sha256
(base32
- "0ghbanj142n0hgydzfjmnkdgri2kswsjal3mn10c723kih4ir4yr"))
- (file-name (git-file-name name version))))
+ "0pbpaasd7kj6y25nm45y1qyb9sxd4570f7g6zkfcpf6pa3nx7qkq"))
+ (file-name (git-file-name name version))
+ (patches (search-patches "gpodder-disable-updater.patch"))))
(build-system python-build-system)
(native-inputs
`(("intltool" ,intltool)
diff --git a/gnu/packages/patches/gpodder-disable-updater.patch b/gnu/packages/patches/gpodder-disable-updater.patch
new file mode 100644
index 0000000000..1aa0afe4f1
--- /dev/null
+++ b/gnu/packages/patches/gpodder-disable-updater.patch
@@ -0,0 +1,18 @@
+Description: Modify the default value for check_on_startup to false.
+ This prevents an privacy/information disclosure unless the user
+ explicitly opts-in for the update check.
+Forwarded: not-needed
+Origin: vendor
+Author: tony mancill <tmancill@debian.org>
+
+--- a/src/gpodder/config.py
++++ b/src/gpodder/config.py
+@@ -93,7 +93,7 @@
+
+ # Software updates from gpodder.org
+ 'software_update': {
+- 'check_on_startup': True, # check for updates on start
++ 'check_on_startup': False, # check for updates on start
+ 'last_check': 0, # unix timestamp of last update check
+ 'interval': 5, # interval (in days) to check for updates
+ },