summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/glib.scm20
-rw-r--r--gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch30
2 files changed, 8 insertions, 42 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 4f18ef7a88..486cdb6add 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -197,18 +197,17 @@ dynamic loading, and an object system.")
(define gobject-introspection
(package
(name "gobject-introspection")
- (version "1.42.0")
+ (version "1.38.0")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.gnome.org/pub/GNOME/sources/"
- "gobject-introspection/" (version-major+minor version)
- "/gobject-introspection-" version ".tar.xz"))
+ "gobject-introspection/"
+ (substring version 0 (string-rindex version #\.))
+ "/gobject-introspection-"
+ version ".tar.xz"))
(sha256
- (base32 "1xwm7wmr9r9wp6xljb3bckx3a4siybavaq39w46ly7gpskxfv8iv"))
- (patches (list
- (search-patch "gobject-introspection-cc.patch")
- (search-patch
- "gobject-introspection-absolute-shlib-path.patch")))))
+ (base32 "0wvxyvgajmms2bb6k3pf1rdpnd79xdxamykzvxzmcyn1ag9yax9m"))
+ (patches (list (search-patch "gobject-introspection-cc.patch")))))
(build-system gnu-build-system)
(inputs
`(("bison" ,bison)
@@ -229,10 +228,7 @@ dynamic loading, and an object system.")
(directories '("lib/girepository-1.0")))))
(search-paths native-search-paths)
(arguments
- `(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
- ;; some tests to fail.
- #:tests? #f
- #:phases
+ `(#:phases
(alist-cons-before
'configure 'patch-paths
(lambda _
diff --git a/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch b/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
deleted file mode 100644
index d00cc5a420..0000000000
--- a/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-# Names of libraries included in typelib files are opened by dlopen. Here we
-# add the full path.
-#
-# This patch was provided by Luca Bruno <lucabru@src.gnome.org> for
-# 'gobject-introspection' 1.40.0 in Nix.
---- ./giscanner/utils.py.orig 2014-08-14 22:05:05.055334080 +0200
-+++ ./giscanner/utils.py 2014-08-14 22:05:24.687497334 +0200
-@@ -110,17 +110,11 @@
- if dlname is None:
- return None
-
-- # Darwin uses absolute paths where possible; since the libtool files never
-- # contain absolute paths, use the libdir field
-- if platform.system() == 'Darwin':
-- dlbasename = os.path.basename(dlname)
-- libdir = _extract_libdir_field(la_file)
-- if libdir is None:
-- return dlbasename
-- return libdir + '/' + dlbasename
-- # From the comments in extract_libtool(), older libtools had
-- # a path rather than the raw dlname
-- return os.path.basename(dlname)
-+ dlbasename = os.path.basename(dlname)
-+ libdir = _extract_libdir_field(la_file)
-+ if libdir is None:
-+ return dlbasename
-+ return libdir + '/' + dlbasename
-
-
- def extract_libtool(la_file):